No audio with NoMachine Workstation

Forums / NoMachine Terminal Server Products / No audio with NoMachine Workstation

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #24749
    Avatarikulis
    Participant

    Hi,

    I just downloaded NoMachine workstation and works quite well only the audio is missing.

    From what I see on the client the nxplayer so not registered in applications.

    Server: nomachine-workstation_6.8.1_1, Debian 10, Qt: 5.11.3, KDE Frameworks: 5.54.0, kf5-config: 1.0

    Client: NXPLAYER – Version 6.8.1, Debian 10, Qt: 5.11.3, KDE Frameworks: 5.54.0, kf5-config: 1.0

    Anybody has similar issues knows how to get audio working?

    #24832
    Avatarkroy
    Contributor

    Which audio framework do you have installed? Please try use workaround from the article:

    https://www.nomachine.com/AR11P01006.

    #24835
    Avatarikulis
    Participant

    I have phonon on both:

    root@debian:~# dpkg -l | grep phonon
    ii libphonon4:amd64 4:4.10.2-1 amd64 multimedia framework from KDE – core library
    ii libphonon4qt5-4:amd64 4:4.10.2-1 amd64 multimedia framework from KDE using Qt 5 – core library
    ii phonon:amd64 4:4.10.2-1 amd64 multimedia framework from KDE using Qt 4 – metapackage
    ii phonon-backend-gstreamer:amd64 4:4.9.0-1 amd64 Phonon GStreamer 1.0 backend
    ii phonon-backend-gstreamer-common:amd64 4:4.9.0-1 amd64 Phonon GStreamer 1.0.x backend icons
    ii phonon4qt5:amd64 4:4.10.2-1 amd64 multimedia framework from KDE using Qt 5 – metapackage
    ii phonon4qt5-backend-vlc:amd64 0.10.2-1 amd64 Phonon4Qt5 VLC backend

    After installing the pavucontrol and setting the output to “Simultaneous output to NoMachine output” audio started working.

    Thks for help.

    Attachments:
Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.