No audio with PulseAudio system instance

Forums / NoMachine for Linux / No audio with PulseAudio system instance

This topic contains 4 replies, has 2 voices, and was last updated by Avatar kroy 3 weeks, 6 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24041
    Avatar
    sbeaulieu
    Participant

    My Linux setup with a NoMachine server runs the pulse audio server as a system instance (i.e. system-instance=yes in /etc/pulse/daemon.conf). When the audio server is started it runs as user ‘pulse’.

    Now when I connect to the NoMachine server from another machine, I use a different user (i.e. not user ‘pulse’) to authenticate. The problem is that audio does get sent to the NoMachine client. If I run ‘pactl list sources’ on the NoMachine server, it verified that the nx audio devices are not created.

    The only way I can get it to work is if I create an non-system instance of the pulse audio server that is launched from the same user that I authenticate with the NoMachine client. In this case the nx audio devices are created and audio works. Is this a limitation or is there a setting somewhere that I am missing?

    #24053
    Avatar
    kroy
    Contributor

    Hi.

    Please edit /etc/pulse/daemon.conf

    change daemonize = no to daemonize = yes
    change system-instance = no to system-instance= yes

    – edit /etc/default/pulseaudio

    change PULSEAUDIO_SYSTEM_START=0  to PULSEAUDIO_SYSTEM_START=1

    – delete .pulse in your home directory and do the same fore other users

    – reboot the system

    If the problem still apears, please extract logs: sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log/node and send them to forum[at]nomachine[dot]com. Make sure that you are connected to session during collection of the logs (in case SessionLogClean is disabled).

    #24057
    Avatar
    sbeaulieu
    Participant

    Thank you for the assistance. I updated daemon.conf, but I didn’t have /etc/default/pulseaudio so I tried running once without it, then again when I created the file and added PULSEAUDIO_SYSTEM_START=1.

    I verified that audio could be heard on the server, but it is still not heard on the client. I will send the logs as instructed. Thanks!

    #24187
    Avatar
    sbeaulieu
    Participant

    I think I’m closer to a solution. I added the ‘nx’ user to the ‘pulse-access’ group, which seemed to eliminate the ‘/bin/pactl no found’ error messages I was getting in the log. The other error I have is that “pactl load-module¬† module-cli-protocol-unix socket=…” is failing with error “Unable to open cli socket.” I have ports 4000/tcp and 4309/udp open in the firewall. Is there anything else I need?

    #24189
    Avatar
    kroy
    Contributor

    Please verify if following /usr/NX/etc/node.cfg keys are set like there:

    AudioInterface pulseaudio
    CommandStartPulseAudio "/usr/bin/pulseaudio --high-priority=no"

    Check also if pulseudio is in the /usr/bin/pulseaudio on the system

    Restart nxserver (sudo /usr/NX/bin/nxserver --restart) to make changes effect.

    If problem will still appears enable debug (nxserver and nxnode) on server side, reproduce problem and send logs to forum[at]nomachine[dot]com? Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT10O00162#1.

    Please send also output of the pactl_list command (pactl list > pactl_list.log).

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.