No available desktops on this server

Forums / NoMachine for Windows / No available desktops on this server

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #38057
    n8johnson
    Participant

    Been having some issues with connecting from a Win 10 PC to a Mac. I continually receive the message “No available desktops on this server”. I’ve tried restarting the service, rebooting the server and reinstalling. I keep having these issues. I wasn’t sure if I should post this on the Mac forum or the Windows forum. Any help would be appreciated. Thanks.

    Attachments:
    #38064
    Britgirl
    Keymaster

    Hi, can you tell us what macOS version it is?

    #38070
    n8johnson
    Participant

    Sure, it’s Monterery 12.3

    #38092
    Britgirl
    Keymaster

    We aren’t aware of “no available desktops” errors when connecting to Monterey.

    Can you enable debug, reproduce the problem, (restart nxserver, connect using nxplayer ), then collect logs and send to forum[at]nomachine[dot]com.

    To enable debug on the Mac, follow the instructions here: https://knowledgebase.nomachine.com/DT11R00181#1.3.

    #38099
    n8johnson
    Participant

    I enabled logs and attached what was produced. Thanks

    #38164
    JimmyBlue
    Participant

    This issue has also started appearing for me in the last couple of days. Running Enterprise Desktop.

    I have made no changes at all to my system (Ubuntu Desktop20.04), it seems to have started after the 7.9.2 update.

    I seem to be able to work around it by running /usr/NX/bin/nxserver --restart via ssh but it is a nuisance.

    #38167
    Britgirl
    Keymaster

    To JimmyBlue, you are running Linux and it would be better in a separate topic to not confuse NoMachine macOS users.

    You can either open a separate topic or since you have Enterprise Desktop installed, and you are also probably entitled to support as part of your subscription, you can open a support ticket from your customer area. Our team will be happy to help.

    #38196
    Britgirl
    Keymaster

    m8johnson, the logs you submitted were not complete. Let’s try again with the automatic procedure. Please see here:

    https://knowledgebase.nomachine.com/DT11R00182#2

    Enable (with sudo /etc/NX/nxserver –debug –enable all), reproduce the problem, gather up the logs. They can be submitted to forum forum[at]nomachine[dot]com if they are too big to attach here.

    #38198
    n8johnson
    Participant

    OK, I enabled debug mode, attempted to connect and reproduced the issue. I’ve sent the logs through email, as they were too large to upload here. Thanks

    #38221
    og00r
    Contributor

    We can see in nxserver.log in home directory, that localnode stuck / dying when it tries to get access.

    25019 25019 2022-04-05 07:44:07 676.173 NXNODE libnxhn::NXSimulateEvent(1) start.
    Load failed: 5: Input/output error
    Try running <code>launchctl bootstrap</code> as root for richer errors.

    Can you run ps -ef | grep nx and check if there is any nxnode process running with parameter --localsession?
    If there is no such process, then it probably died. This can happen when nomachine is restarted on login window or when vnc session is running.

    Do you have maybe any vnc sessions on that machine?

    If process died unexpectedly, there should be a core dump file or diagnostic report. Please check directories below if there is a new one related to nxnode process:

    ~/Library/Logs/DiagnosticReports
    /Library/Logs/DiagnosticReports
    /cores/

    Could you also confirm that the user is logged on to his session when nxserver --restart is executed?

Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.