No available desktops on this server – Mint 20.2

Forums / NoMachine for Linux / No available desktops on this server – Mint 20.2

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #36649
    farrenp
    Participant

    Hi looking for help getting a desktop running on a Linux Mint 20.2 server

    Connecting from local machine:

    Windows 10 Pro, NoMachine 7.7.4

    To remote server

    Linux Mint 20.2, NoMachine 7.7.4, Cinnamon 5.0.7

    Getting the following message “Cannot detect any display running. Do you want….”

    When I select Yes, I get the “<No available desktops on this server>”

    Can you help please?

    I have attached the .nx logs from Linux server

    Thanks

     

     

    #36693
    Britgirl
    Keymaster

    We aren’t able to reproduce this problem. The logs didn’t include the server-side logs which is where the problem is.

    It could be a problem with permissions or the user’s home directory is missing?

    What is the output of this in a terminal on the server?  ls -ltra /home/support/.nx

    #36696
    farrenp
    Participant

    On Server:

    Contents of /home/support/.nx is attachment ServerUser-support.nx.tar.gz

    Contents of /usr/NX/var/log is attachment NoMachine-log.tar.gz

     

    support ~ $ ls -ltra /home/support/.nx

    total 48

    -rw——-  1 support support     0 Dec 16 16:36 nxerror.log

    drwx——  2 support support  4096 Dec 16 16:36 nxdevice

    drwx——  2 support support  4096 Dec 16 16:36 F-M-farrenpLaptop-13001-05BB971A6E98362D3E4523A84F9D77FF

    drwx——  2 support support  4096 Dec 16 16:36 config

    drwxr-xr-x  2 support support 12288 Dec 16 16:36 fonts

    drwxr-xr-x  2 support support  4096 Dec 16 16:43 temp

    drwx——  2 support support  4096 Dec 16 16:43 M-farrenpLaptop-13001-C653C43022ACB67C75117815829B824F

    drwx——  9 support support  4096 Dec 16 16:43 .

    -rw——-  1 support support   849 Dec 16 16:43 nxserver.log

    drwx——  4 support support  4096 Dec 16 16:43 node

    drwxr-xr-x 43 support support  4096 Dec 16 16:49 ..

     

    #36699
    farrenp
    Participant

    Client side logs attached.

    #36722
    Britgirl
    Keymaster

    You sent the .nx folder from the server side, but what we need is the server logs.

    It could be worth trying a reinstall of NoMachine first. If that doesn’t help, enable debug, restart, reproduce and send us /usr/NX/var/log. To enable debug, please see the instructions here: https://knowledgebase.nomachine.com/DT11R00181#1.1. Send the logs to forum[at]nomachine[dot]com using the title of the topic as the subject of your email.

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.