No available desktops on this server (Ubuntu 20.04)

Forums / NoMachine for Linux / No available desktops on this server (Ubuntu 20.04)

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #39635
    alejandro
    Participant

    Hi, I am trying to connect within my home local network into a server on Ubuntu 20.04 using a client that is also on Ubuntu 20.04. Both have graphical interfaces (Gnome, 3.36.8) that work normally and that I can log into at the keyboard. Both were installed from ‘nomachine_7.10.1_1_amd64.deb’.

    This worked in the past, but upon returning to NoMachine after a few months of inactivity, when I connect from the client it seems that I can log in (authentication seems to work OK) but I get the message that “<No available desktops on this server>”.

    After tinkering to find a solution (I think all I changed was attempting to connect with or without a logged in user on the server), I now get essentially the same, but preceded by the prompt “Cannot detect any display running. Do you want NoMachine to create a new display and proceed to connect to the desktop?” If I click Yes I get to the same state “<No available desktops on this server>” as before.

    I’ve tried restarting the server, as well as removing and re-installing NoMachine on the server. Based on looking at the forum, I found a few users with the same symptoms but I could not resolve. Here are three pieces of evidence that might be relevant:

    i) On the server at /usr/NX/etc/server.cfg  I have a line that reads:

    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,physical-desktop,shadow,unix-xsession-default,unix-gnome,unix-xdm

    ii)  On the server at /home/<user>/.nx/nxserver.log I have lines that read
    1271612 1271612 2022-08-08 22:31:40 795.914 NXNODE   WARNING! Process ‘/usr/NX/bin/nxclient –monitor –pid 2732’ with pid ‘1271631/1271631’ finished with signal 9 after 548,614 seconds.

    1271612 1271612 2022-08-08 22:31:40 797.052 NXNODE   WARNING! NXClientMonitor: NXClient –monitor exited with code 9. Restarting nxclient –monitor.

    1271612 1271612 2022-08-08 22:31:40 803.079 NXNODE   WARNING! Cannot open: /home//.nx/node/C–1002-95F02D852F1BA3C3D27CBD1BF405C34B/client/directory.

    1271612 1271612 2022-08-08 22:31:40 803.201 NXNODE   WARNING! Error is: 2, ‘No such file or directory’.

    1271612 1271612 2022-08-08 22:31:40 803.265 NXNODE   WARNING! Could not create file: /home//.nx/node/C–1002-95F02D852F1BA3C3D27CBD1BF405C34B/client/directory.

    1271612 1271612 2022-08-08 22:31:40 803.318 NXNODE   WARNING! Error is 2, No such file or directory.

    Looking into the files mentioned in (ii), at /home/<user>/.nx/node/C-<hostname>-1002-95F02D852F1BA3C3D27CBD1BF405C34B/client I only have the files cookie and pid, but there is also a directory at /home/<user>/.nx/node/F-C-<host>-1002-95F02D852F1BA3C3D27CBD1BF405C34B/client with the files cookie, pid and directory.

    iii) $ grep ‘DefaultDesktopCommand’ /usr/NX/etc/node.cfg

    DefaultDesktopCommand "dbus-launch --exit-with-session gnome-session --session=ubuntu"

    I followed the short instructions at https://kb.nomachine.com/DT11R00182#1 and created a log zip file, which I can send if requested.

    Thank you,

    A.

     

    #39729
    Britgirl
    Keymaster

    Default Ubuntu 20.04 installs and works out-of-the-box in our labs.

    Are you running Wayland and is it a VM? If so, take a look at this article and follow the tips there:

    Connecting to a Wayland-based desktop running in a Linux virtual machine
    https://kb.nomachine.com/AR04R01083

    You could also log out and then log in, but to a X.org desktop. This will show whether the problem is Wayland or not.

    Send the logs by all means, we can take a look and see what’s going on. Please send them to forum[at]nomachine[dot]com making sure to put the title of your topic as the subject of your email. Thanks!

    #39789
    alejandro
    Participant

    Hi, thanks for the reply. Neither machine uses Wayland, and neither is a VM. I’ve sent logs to the email, thanks again!

    #39791
    Britgirl
    Keymaster

    Thanks for the attachments, but we would need server-side logs with debug enabled to be able to understand what is happening. Please see the following document for instructions on how to extract the logs, https://kb.nomachine.com/DT11R00182, and submit them again. Thanks!

    #39845
    Britgirl
    Keymaster

    From the logs it appears that the agent (nxnode) is hanging. We would need more information.

    Can you find the nxnode pid and run this command in a terminal:

    sudo gdb -batch -ex “thr apply all bt” -p <nxnode_pid>

    Then show us the whole output. If you have more than one nxnode process running, repeat for each nxnode.
    Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.