No available session on this server on Odroid

Forums / NoMachine for ARM / No available session on this server on Odroid

This topic contains 1 reply, has 2 voices, and was last updated by Avatar kroy 1 year, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #17513
    Avatar
    rubenvanbeelen
    Participant

    Hi everyone,

    I’m running NoMachine (6.0.78, armlf) on an Odroid XU4 (Ubuntu 14.04) and connecting with a Windows 7 SP1 laptop. Since yesterday I’ve been experiencing some problems. First the Odroid refused the credentials I have been using for some time. I was able to register the same password those again via /usr/NX/bin/nxserver –passwd odroid, but when I connect the client side now gives the following 2 messages:

    “No available sessions on this server”
    “The server was unable to make the local display available or access to the local display is disabled.”.

    I tried enabling the server side logs, but when enabling debug I get the following error:

    NX> 500 ERROR: Cannot enable debug mode for: server.

    NX> 500 ERROR: Key SessionLogLevel does not exist in /usr/NX/etc/server.cfg

    I also noticed that when I don’t connect a HDMI monitor, the system doesn’t want to boot at all, which might also include some trouble with starting the virtual desktop.

    Thanks in advance.

     

    #17534
    Avatar
    kroy
    Contributor

    Did you perhaps change something in the server.cfg file? Please send file list from NoMachine’s etc directory (sudo find /usr/NX/etc/ > list_of_files.txt), server.cfg, logs (please tar /usr/NX/var/log directory as root) and send it to forum[at]nomachine[dot]com.

    A restoration of server.cfg could fix the problem. If you didn’t make a backup before changes, you can use default file: /usr/NX/etc/server-debian.cfg.sample.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.