No available sessions (local display disabled) on Fedora 21

Forums / NoMachine for Linux / No available sessions (local display disabled) on Fedora 21

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5763
    wernermaes
    Participant

    Although my X server is running

    root      1412  0.5  6.1 179988 127048 tty1    Ss+  10:37   0:05 /usr/libexec/Xorg.bin :0 -background none -noreset -verbose 3 -logfile /dev/null -auth /run/gdm/auth-for-gdm-rdSSrj/database -seat seat0 -nolisten tcp vt1

    and it’s possible to login (NoMachine server free version 4.4.1, client 4.4.1 on fedora 21) I cannot open a physical desktop (no available sessions on this server).

    On Fedora 20 with version 4.3.30 this works fine.

    Any ideas?

    #5768
    wernermaes
    Participant

    Here are some relevant pieces of the debug log

    2014-12-18 14:06:41 934.870  4004 NXSERVER checkLocalSession: Found socket for display [0] – [unix  2      [ ACC ]     STREAM     LISTENING     17659    @/tmp/.X11-unix/X0]
    2014-12-18 14:06:41 935.030  4004 NXSERVER Going to find X server for display: [0]
    2014-12-18 14:06:41 935.612  4004 NXSERVER Found X server process: [Xorg.bin        /usr/libexec/Xorg.bin :0 -background none -noreset -verbose 3 -logfile /dev/null -auth /run/gdm/auth-for-gdm-WT4O6X/database -seat seat0 -nolisten tcp vt1]
    2014-12-18 14:06:41 935.823  4004 NXSERVER checkLocalSession: Found authority /run/gdm/auth-for-gdm-WT4O6X/database.
    2014-12-18 14:06:41 935.988  4004 NXSERVER checkLocalSession: Found seat seat0.
    2014-12-18 14:06:41 936.290  4004 NXSERVER Found node assigned to display 0.
    2014-12-18 14:06:41 936.609  4004 NXSERVER Session for display 0 not changed. Skip recognition.
    2014-12-18 14:06:41 936.819  4004 NXSERVER recognizeXSession: kind [session] based on command [mate-session    mate-session] pid [1507]
    2014-12-18 14:06:41 937.283  4004 NXSERVER checkLocalSession: Found socket for display [1001] – [unix  2      [ ACC ]     STREAM     LISTENING     41507    /tmp/.X11-unix/X1001]
    2014-12-18 14:06:41 937.446  4004 NXSERVER Going to find X server for display: [1001]
    2014-12-18 14:06:41 938.330  4004 NXSERVER checkLocalSession: Found socket for display [1001] – [unix  2      [ ACC ]     STREAM     LISTENING     41506    @/tmp/.X11-unix/X1001]
    2014-12-18 14:06:41 938.487  4004 NXSERVER Going to find X server for display: [1001]
    2014-12-18 14:06:41 939.473  4004 NXSERVER Found node assigned to session pid 1507.
    2014-12-18 14:06:41 939.757  4004 NXSERVER NXPL was already loaded.
    2014-12-18 14:06:41 939.919  4004 NXSERVER NXPL::NXGetRandomString start.
    2014-12-18 14:06:41 940.071  4004 NXSERVER NXPL::NXGetRandomString stop.
    2014-12-18 14:06:41 940.291  4004 NXSERVER isLoginWindowByNXPL random string: 61F8ABE74EE2E298C32BF4DBB733AD24
    2014-12-18 14:06:41 940.489  4004 NXSERVER isLoginWindowByNXPL tempfile: /var/NX/nx/.nx/61F8ABE74EE2E298C32BF4DBB733AD24.lcookie_2
    2014-12-18 14:06:41 940.971  4004 NXSERVER isLoginWindowByNXPL addCookie(/var/NX/nx/.nx/61F8ABE74EE2E298C32BF4DBB733AD24.lcookie_2, :0, MIT-MAGIC-COOKIE-1, ********) return 0
    2014-12-18 14:06:41 941.206  4004 NXSERVER isLoginWindowByNXPL set XAUTHORITY to /var/NX/nx/.nx/61F8ABE74EE2E298C32BF4DBB733AD24.lcookie_2
    2014-12-18 14:06:41 941.379  4004 NXSERVER isWMRunningByDisplay call on :0
    2014-12-18 14:06:41 942.891  4004 NXSERVER NXPL::NXWmRunning(:0) [1]
    2014-12-18 14:06:41 943.067  4004 NXSERVER isLoginWindowByNXPL isWMRunningByDisplay return [1]
    2014-12-18 14:06:41 943.301  4004 NXSERVER isLoginWindowByNXPL clean out file: /var/NX/nx/.nx/61F8ABE74EE2E298C32BF4DBB733AD24.lcookie_2
    2014-12-18 14:06:41 943.572  4004 NXSERVER isLoginWindowByNXPL(0, ********) return [1]
    2014-12-18 14:06:41 943.797  4004 NXSERVER PhysicSessions::isLoginWindowByCK missed all checkpoints

    #5798
    Britgirl
    Keymaster

    This seems to be an issue with SELinux. We are working on changes to our SELinux modules in order to make it work on FC21. Does disabling SELinux help?

    https://docs.fedoraproject.org/en-US/Fedora/11/html/Security-Enhanced_Linux/sect-Security-Enhanced_Linux-Enabling_and_Disabling_SELinux-Disabling_SELinux.html

    #5801
    wernermaes
    Participant

    Hello

    I had already disabled SElinux. So it seems not to be related to Selinux

    [root@fedora21 nx]# getenforce

    Disabled

     

     

    #5804
    Britgirl
    Keymaster

    Please try to run the following command from a console on the server:

    NX_ROOT=/usr/NX NX_SYSTEM=${NX_ROOT} LD_LIBRARY_PATH=${NX_ROOT}/lib:${NX_ROOT}/lib:$LD_LIBRARY_PATH bash -c ‘${NX_ROOT}/bin/nxkeygen -u’

    and show us the output.

    If command above doesn’t return an error, please try to fix the problem as follows.

    1) Remove uuid file:

    sudo rm /usr/NX/etc/uuid

    2) Update the NoMachine server installation:

    sudo /usr/NX/scritps/nxserver –update

    Then, please send us the following file:

    /usr/NX/var/log/nxupdate.log

    #5862
    wernermaes
    Participant

    [root@fedora21 ~]# NX_ROOT=/usr/NX

    [root@fedora21 ~]#  NX_SYSTEM=${NX_ROOT}
    [root@fedora21 ~]# LD_LIBRARY_PATH=${NX_ROOT}/lib:${NX_ROOT}/lib:$LD_LIBRARY_PATH
    [root@fedora21 ~]# bash -c ${NX_ROOT}/bin/nxkeygen -u
    /usr/NX/bin/nxkeygen: error while loading shared libraries: libnx.so: cannot open shared object file: No such file or directory
    [root@fedora21 ~]# locate libnx.so
    /usr/NX/lib/libnx.so

    after exporting LD_LIBRARY_PATH (export LD_LIBRARY_PATH)

    [root@fedora21 ~]# bash -c nxkeygen -u
    14234 14234 11:08:13 665.753 Main: ERROR! Usage: nxkeygen [-k privatekey [-c certificate] [-p publickey] [-t type]] [-r] [-n length] [-u].

    [root@fedora21 init]# /usr/NX/scripts/setup/nxserver –update
    NX> 701 Starting update at: Tue Jan 06 11:15:31 2015.
    NX> 701 Updating: nxclient version: 4.4.1.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Client update completed with warnings.
    NX> 701 Please review the update log for details.
    NX> 701 Updating: nxplayer version: 4.4.1.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Updating: nxnode version: 4.4.1.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Saving configuration file to: /usr/NX/etc/node.cfg.backup.
    NX> 701 Creating configuration in: /usr/NX/etc/node.cfg.

    Support for these types of sessions is available:
    physical-desktop,shadow,unix-xsession-default,unix-gnome,unix-xdm,vnc
    You can enable this by running:
    /usr/NX/scripts/setup/nxnode –availablesessionsetup

    NX> 701 Node update completed with warnings.
    NX> 701 Please review the update log for details.
    NX> 701 Updating: nxserver version: 4.4.1.
    NX> 701 Using installation profile: Fedora.
    NX> 701 Update log is: /usr/NX/var/log/nxupdate.log.
    NX> 701 Saving configuration file to: /usr/NX/etc/server.cfg.backup.
    NX> 701 Creating configuration in: /usr/NX/etc/server.cfg.ls

     

     

    #5913
    Britgirl
    Keymaster

    Did you send on the nxupdate.log to issues[at]…?

    #5920
    wernermaes
    Participant

    I’ve sent it now.

    Kind regards

    Werner

    #6217
    zaq
    Contributor

    Hello,
    Could you try to update to 4.4.6, please? There is a fix for SELinux
    Fedora 21.
    If the issue persists please gather debug information following the
    instructions here:

    https://www.nomachine.com/AR07K00677

    Also please save active processes:

    ps -Af | grep nx > processes.txt

    Send debug information and ‘processes.txt’ to issues[at]nomachine[dot]com.

    #6274
    wernermaes
    Participant

    Hello

    Updating to version 4.4.6 solves this issues.

    Thank you for your support !

    Werner

Viewing 10 posts - 1 through 10 (of 10 total)

This topic was marked as solved, you can't post.