"No available sessions on this server" error

Forums / NoMachine for Linux / "No available sessions on this server" error

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #449
    Avatarvolenin
    Participant

    Hi. I’m having issues installing NX Server on Ubuntu Server 13.04. Here is what I had setup up to this point:

    – Ubuntu Server 13.04, minimal install + some misc packages
    – kde-plasma-desktop package
    – NXClient 4.0.x on Windows 7
    – NXServer 4.0.x on Ubuntu Server

    KDM upstart script is ‘disabled’ to make sure it does not autostart on system boot (by creating /etc/init/kdm.override file with ‘manual’ text inside).

    When I’m trying to connect to Ubuntu server I’m getting ‘No available sessions on this server’ message in the client app (no matter whether I’m trying to connect through NX or SSH protocol). On the server, the nxserver.log file contains following entries:

    21:43:33:885.449 NXNODE-4.0.362[24156] WARNING: Cookie not found at []
    21:43:33:887.985 NXSERVER-4.0.362[24067] WARNING: Line [1001:xbmc:0:ubuntu:desktop:session:1449:empty:] do not match regular expression.
    21:43:33:936.521 NXSERVER-4.0.362[24067] ERROR: An error occurred while parsing session line: Not local session found

    Other entries in the log indicate that connection from the client does make it to the server:

    21:04:32:162.322 NXSERVER-4.0.362[15919] User ‘volenin’ logged in from ‘192.168.1.53’.

    I used to run NXServer 3.5 before on Ubuntu 10.10 and from what I recall it was running pretty much out of the box… Any suggestions would be greatly appreciated.

    Vlad

    PS: does ubuntu server have to already have an XServer or Desktop Manager running? From what i understand, it instantiates everything dynamically… Should xorg.conf be setup in some particular way?..

    #454
    Avatarsil04
    Keymaster

    Hi volenin,

    which package did you install on Ubuntu (e.g. NoMachine, Workstation) ?

    does ubuntu server have to already have an XServer or Desktop Manager running

    Yes, the XServer must be running to be able to connect to the physical desktop.

    NoMachine (the free version) lets you access the physical desktop remotely and requires that the Xserver is running. You can also use NoMachine on a headless Linux server (without the need of having the X server running), more instructions are available here:

    https://www.nomachine.com/AR10K00710

    Any of the products from the Terminal Server range (e.g. Workstation or Terminal Server, https://www.nomachine.com/enterprise), allows to create virtual desktop sessions. In this case it’s not necessary to have the Xserver running.

    #514
    Avatarvolenin
    Participant

    The package I installed on Ubuntu was ‘NoMachine for Linux – amd64’ (http://web04.nomachine.com/download/4.0/Linux/nomachine_4.0.362_1_amd64.deb).

    I currently don’t have XServer running, which is probably why it doesn’t work (especially that the instructions you pointed me to do contain some reference to the cookies, etc, which according to the log file is currently missing, which makes sense).

    I wonder if the behavior of XServer has changed since version 3.5? I’m pretty sure everything was instantiated ‘on the fly’ and i wasn’t setting up xserver explicitly back then (through i did have different package installed on Ubuntu server – kubuntu-desktop if i’m not mistaken).

    #517
    Avatarvolenin
    Participant

    … to clarify last paragraph: has the behavior of the ‘free’ version of NXServer changed to compare with version 3.5 of NX Free Edition?

    #524
    Avatartitan
    Participant

    has the behavior of the ‘free’ version of NXServer changed to compare with version 3.5 of NX Free Edition

    Yes. The free version of NoMachine now works as traditional remote access software.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.