No available sessions, RHEL 7

Forums / NoMachine for Linux / No available sessions, RHEL 7

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #4388
    AvatarRoamio
    Participant

    I’ve installed NX 4 on a Windows 8 desktop and two Redhat Linux workstations.  I was able to connect from Windows to the RHEL 6.4 server but was getting the “No available sessions” error when trying to connect the RHEL7 server.  I found these errors in the /usr/NX/var/log/nxerror.log file:

    bash: netstat: command not found…

    bash: ck-list-sessions: command not found…

    I copied netstat and ck-list-sessions from the 6.4 to the 7 server and am now able to connect to both boxes.

    #4410
    Avatarnars
    Contributor

    Hello Roamio,

    could you please give us information about the kind of installation media of this RHEL7? (i.e. was it boot.iso or dvd.iso?).

    Did you uncheck installation of any default packages during system installation?

    #4415
    AvatarRoamio
    Participant

    It was installed from the dvd.iso with a kickstart file that included the following:

    %packages

    @debugging

    @desktop-debugging

    @development

    @fonts

    @gnome-desktop

    @internet-browser

    @x11

    @print-client

     

    libaio-devel

    compat-libcap1

    ksh-20120801

    sysstat

    wget

    java-1.7.0-openjdk-devel

    %end

    I understand that netstat is deprecated and that ss should be used in its’ place.

    #4421
    Avatarnars
    Contributor

    Currently netstat is required for the proper working of NoMachine. This should be changed in future versions. You can install it by installing net-tools package:

    sudo yum install net-tools

     

    ck-list-sessions is not required, message about that it is not found is a cosmetic issue and also should be fixed in next versions.

    #4475
    AvatarRHELuser
    Participant

    Dear all,

    I’ve got also a problem with RHEL7 and virtual desktop. I’ve installed NoMachine Workstation 4.2.27-2 version on RHEL7 server and NoMachine 4.2.27-2 client version on CentOS 6.2.

    I be able to connect to the physical display but i’ve got an error when i try to use a virtual desktop : “Oh no! Something has gone wrong”

    And i’ve got only “Logout” button.

    Did you have this error?

    Thanks.

    #4480
    AvatarBilbotine
    Keymaster

    Hi RHELuser,

    Currently Gnome 3 (default desktop in RHEL7) doesn’t work in virtual sessions.

    A workaround is provided in the article “Supporting the default Gnome 3 on Fedora 15 or later with NoMachine” (https://www.nomachine.com/AR06L00806)

    NoMachine 5.0 will enable Gnome 3 and Unity in virtual sessions.

    #4483
    AvatarRHELuser
    Participant

    Thank you for your response.

    This workaround works.

    Do you know the release date of NoMachine 5?

    • This reply was modified 6 years, 11 months ago by AvatarRHELuser.
    #5147
    AvatarBritgirl
    Keymaster

    An approximate time could be the second quarter of 2015 (provided that development goes smoothly between then :-)) We’ll keep you updated via the forums.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as closed, you can't post.