No connection to Ubuntu Linux: The session negotiation failed

Forums / NoMachine for Linux / No connection to Ubuntu Linux: The session negotiation failed

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #27409
    Avatarcord
    Participant

    I experienced the same issue as described in https://forums.nomachine.com/topic/fails-to-conect-to-linux-nxserver while connecting from a Windows NX client to a Linux NX server 6.9.2 running on Ubuntu 18.04.4 with the same entries in nxserver.log:

     

    2020-05-13 09:57:30 216.743   711 NXSERVER ERROR! Cannot list directory content.2020-05-13 09:57:30 216.858   711 NXSERVER ERROR! Error is: 13, Permission denied.

    2020-05-13 10:08:36 114.280 19655 NXSERVER User ‘<user>’ logged in from ‘10.21.253.251’ using authentication method NX-private-key.

    2020-05-13 10:08:36 424.084 19655 NXSERVER WARNING! Cannot open: /usr/NX/var/db/limits/sessions.<user>.

    The root cause was the wrong owner of the folder limits:

    drwx—— 2 root root  4096 Mai 13 02:18 limits

    Fixing it from owner root to owner nx solved this issue.

    In the session before I updated Ubuntu with > sudo apt-get upgrade, but unfortunately I cannot remember the packages being installed. Furthermore I noticed that after fixing and restarting, NX immediately asked for updating the server on Linux to 6.10.12. To me it looks as if maybe refreshing some directories, possibly due to the pending update, result in the wrong directory having owner root. I hope these observations help fixing this issue.

    #27547
    AvatarBritgirl
    Keymaster

    Hi, thanks for taking the time to report this. There was a hitch with the manifest in the update server, but it has since been fixed 🙂 See these two topics for reference:

    Session negotiation has failed

    Session Negotiation failed – running db

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.