No connection via public IP possible

Forums / NoMachine for Linux / No connection via public IP possible

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32552
    Avatarbpe
    Participant

    Hello!

    I recently installed NoMachine on my Linux Mint 19.2 machine and connected to it from a Windows 10 laptop on the same network – worked flawlessly.
    I would now like to connect to the Linux machine from outside the network. Unfortunately, this does not work so far.
    I already looked through some threads, here is what I tried:

    On my router, there is no UpNp option. However, I did set up port forwarding from 21960 (WAN) to 4000 (LAN) for the reserved IP of the Linux machine (192.168.178.50). I also have some other port forwarding in place, which works.

    When checking my (static) public IP for the port 21960, it shows me that it is indeed open.

    However, when running sudo nxserver –upnpmap, the output is as follows:

    Local IP                   192.168.178.50

    Gateway IP                 192.168.178.1

    External IP

    In the config file, I tried to comment out/in “NXUPnPPort 21960” and then restarted the server, but no change. “EnableUPnP NX” is active.

    In the GUI under ports, I see the NX port 4000. When configuring and trying to set the checkmark for the gateway port, after a few seconds I get the message “Failed to map the port on the gateway”. The service port reads 4000, the gateway port 21960.

    I appreciate any input. If there are more details you need to know in order to solve my issue, I am happy to provide them.

    All the best,

    bpe

    #32573
    Avatarkroy
    Contributor

    Hi,

    If your router doesn’t support UPnP, External IP won’t show in the nxserver command output or nxplayer GUI. Please try port forwarding (which you already configured). Reverse all UPnP changes you made in server.cfg and make sure if the chosen port is not being used by another service. To connect you need to open a new connection in the nxplayer, enter your Public IP and use forwarded port (in your case 21960).

    #32588
    Avatarbpe
    Participant

    Thanks for getting back to me!

    I think I was trying to connect to port 4000 before, which obviously didn’t work.

    Now, if I put in my public IP and the right port, I get the message: “Could not connect to the server. Error is 22: Invalid argument”

    Based on the documentation (https://www.nomachine.com/TR12R09992), it has to do with a config setting, but I can’t seem to find the relating entry. The only line I find that is called like that is “ClientMenuConfiguration all”, but it’s commented out.

    When trying to switch to SSH as suggested, it tells me that SSH is not supported by the server (most likely due to the free version?).

    I also found a note stating that the username must not contain capital letters. That is not the case here, the user I am trying to connect to is written with no capital letters.

    Again, any input would be appreciated 🙂

    #32630
    Avatarkroy
    Contributor

    Is the local connection still working? If it’s not a problem with the credentials maybe try to unselect “Use UDP communication for multimedia data” (it’s in the player – in connection file) in case UDP ports are blocked in the router.
    Logs from both the client and server side would be helpful to investigate the problem. You can send them to forum[at]nomachine[dot]com, making sure you add the title of the topic as the email subject. Instructions about debugging and collecting logs can be found here: https://www.nomachine.com/DT11R00181.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.