No external ip address

Forums / NoMachine for Windows / No external ip address

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #25075
    Avatarredracer
    Participant

    I am trying to log into my home pc but only see a local ip address. I was previously able to log in before the update to 6.9.2?

    I have tried to edit the gateway port as it changed since the update but i cannot.

     

    Help would be appreciated! Thanks

    #25080
    Avatarkroy
    Contributor

    Are you sure if you ware able to connect before update? If there wasn’t any changes with router configuration you should be still able to connect there.

    Can you check if there is EnableUPnP NX set in the node.cfg file? You can find it in InstallationDirectory/NoMachine/etc/ folder and edit as text file. If there is “none” value or it is commented out (line is beginning with # char) – you need set there “NX” value or uncomment key (delete # from line beginning). Then restart nxserver (click on NoMachine icon on the system tray -> Show the service status -> Restart the nxserver)

    If this is not the case, please open cmd as an administrator, navigate to InstallationDirectory/NoMachine/bin and execute command nxserver --upnpstatus. It should print External IP and port which you should use to connect.

    #25102
    Avatarredracer
    Participant

    Thank you, I tried to locate the EnableUPnP NX set in the node.cfg file but could not find any reference to it? Any further assistance would be appreciated. Thanks

    #25114
    Avatarkroy
    Contributor

    Sorry for that, it should be server.cfg file. It’s in the same place – InstallationDirectory/NoMachine/etc/.

    #25124
    Avatarredracer
    Participant

    Great, thank you Kroy. I have followed the above but still no external ip address listed. only the internal network (home network) ones? Thanks…

    #25127
    Avatarkroy
    Contributor

    What is your router model? Can you check if UPnP is enabled in router settings?

    If problem still appears enable logs on server side (https://www.nomachine.com/DT10O00162#1), restart nxserver, open CMD as an administrator and execute commands:

    cd %ProgramFiles(x86)%\NoMachine\bin
    nxserver --upnpmap

    and send output and collected logs to forum[at]nomachine[dot]com.

    #25140
    Avatarredracer
    Participant

    Finally sorted, thanks for all your help. It seems like it was a setting within the application prompting for permission.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.