No external IP address on Fedora 28; present on Win10

Forums / NoMachine for Linux / No external IP address on Fedora 28; present on Win10

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #19673
    Avatarfhbartlett
    Participant

    While NoMachine 6.2.4 (free) runs on Fedora 28 (Gnome) on a 64-bit Intel desktop, it will not show an external IP address, even though I’ve ensured that

    EnableUPnP NX

    is present in server.cfg. I also do not see a GW Port listed under “Network services,” though I do under Windows — for¬†NoMachine 6.2.4 (free)¬†does produce an external IP address on my Windows 10 laptop (also 64-bit Intel), even though both machines are connected via ethernet cables to the same router.

    The two machines can talk to each other via NoMachine, so all that’s working fine.

    If the problem isn’t in the router, where could it be? There’s got to be a port setting I’m missing somewhere …

    Thanks!

    #19676
    Avatarkroy
    Contributor

    We weren’t able to reproduce this problem (even on Fedora 28). How did you check the external IP? Using the NoMachine Player “Welcome screen” or by using !M icon in the system tray? Maybe you have many interfaces on the list – external IP is on the bottom – is it possible that you didn’t scroll the list and missed it?

    Please check sudo /usr/NX/bin/nxserver --upnpstatus command. It should list external IP and Port (when UPnP is enabled). If it still missing – please send logs with debug from both machines. Instructions about debug and collecting logs you can find here:
    https://www.nomachine.com/DT10O00163.

    After running debug – please restart nxserver (navigate to bin directory, which in default is /usr/NX/bin/ on Linux and %PROGRAMFILES(X86)%\NoMachine\bin on Windows, and execute ./nxserver --restart). Then execute command ./nxserver --upnpmap. Compressed logs from /usr/NX/var/log and %PROGRAMDATA%\NoMachine\var\log please send to forum[at]nomachine[dot]com.

    #19687
    Avatarfhbartlett
    Participant

    My F28 Server Preferences dialogue shows 2 local IP addresses with 2 protocols, of which I see only the top 3 by default:

    nx://10.0.0.xxx

    ssh://10.0.0.xxx

    nx://10.105.xxx.xxx

    ssh://10.105.xxx.xxx

    sudo /usr/NX/bin/nxserver --upnpstatusx

    runs without error, but shows no output, while server.cfg shows

    EnableUPnP NX

    The W10 box shows three IPs:

    nx://10.0.0.xxx

    nx://10.105.xxx.xxx

    nx://174.59.xxx.xxx:xxxx

    Unfortunately, I don’t have admin rights (it’s owned by my employer), so I can’t run nxserver from the command line, nor do I see logs anywhere. But note that I’m much more comfortable with Linux than Windoze …

    #19697
    Avatarkroy
    Contributor

    Are you sure that you executed correct commands or “upnpstatusx” is maybe a typo inside the post?

    In attached logs there is no debug. To enable it:

    Edit /usr/NX/etc/server.cfg, uncomment and set the following:
    SessionLogLevel 7

    Edit /usr/NX/etc/node.cfg, uncomment and set the following:
    SessionLogLevel 7

    Restart server: sudo /usr/NX/bin/nxserver --restart. After that execute: sudo /usr/NX/bin/nxserver --upnpmap and archive logs: sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log.

    Logs from windows would be very helpful.

    To enable it – run notepad as an administrator open server.cfg file (which is in the InstallationDirectory/NoMachine/etc) and uncomment and set the following:
    SessionLogLevel 7

    Repeat the operation for node.cfg. Then run cmd as administrator -> navigate to InstallationDirectory/NoMachine/bin -> execute commands nxserver --restart -> and nxserver --upnpstatus

    Then create a compressed archive of the NoMachine’s /var/log directory.

    The NoMachine /var/log directory is: %PROGRAMDATA%/NoMachine/var/log

    To compress it, right-click the file or folder, point to Send To, and then click Compressed (zipped) Folder.

    #20375
    Avatarfhbartlett
    Participant

    I still have no idea what the trouble was, but it’s fixed.

    I did a fresh install (rather than a dnf update) of Fedora 29 and installed the latest NoMachine; now everything is working as it should.

    #20380
    AvatarBritgirl
    Keymaster

    Thanks for letting us know.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.