No external ip address shown with UPnP enabled

Forums / NoMachine for Linux / No external ip address shown with UPnP enabled

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #11293
    AvatarRed Bow Tie
    Participant

    Have enabled UPnP in my router but still no public ip address is shown. Router is Actiontec R3000. Also have looked at /usr/NX/etc/server.cfg and almost all options except uPnP are commented out. If I try port forwarding do I need to edit the server.cfg file to allow the ports forwarded in the router to be detected by the server? Will that enable me to get my public ip address?

    #11306
    Avatarkroy
    Contributor

    If I try port forwarding do I need to edit the server.cfg file to allow the ports forwarded in the router to be detected by the server?

    You don’t need to edit server.cfg. Configure your router to pass traffic to port 4000 (NX protocol). Instructions on how to connect to NoMachine when the server is behind a NAT router or a firewall you can find there: https://www.nomachine.com/AR11L00827. Read part “IMPORTANT”, there is instruction: “if the router doesn’t accept UPnP or NAT-PMP commands, it will be necessary to configure it manually through its administrative interface.”

    Will that enable me to get my public ip address?

    On NoMachine’s Welcome Screen page IP list? No – if you had disabled UPnP or your router doesn’t accept UPnP commands. In that case you can get your public IP address from whatismyip[dot]com, for example.

    #11311
    AvatarRed Bow Tie
    Participant

    UPnP does not display public IP address with router enabling it. Therefore, need to manually configure it. Port Forwarding found under Firewall. Two options for entry.

    1) Set the local LAN server port and IP information.

    Select Device                     Manually Enter IP Address

    Enter IP Address

    Starting Port

    Ending Port

    Protocol                           (Choice of TCP, UDP, ICMP and GRE)

    Below that have

    2. (All settings optional). Set the RG WAN port to translate the local LAN server port. Set the remote IP to restrict access to only that Internet IP.

    Starting RG WAN port

    Ending RG WAN port

    Remote Internet IP Address                                              (Beside that entry box have 0.0.0.0 will use any IP address

    What should I put in these settings for the default nomachine service port, gateway port? I cannot put a Public IP address in option 1 above as it won’t accept any IP address that is not local (i.e.192.168.xx for example)

    As you say I can easily find my public IP address but where do I put it in the above settings?

    #11319
    AvatarRed Bow Tie
    Participant

    Would the following be correct for the Router settings in post 2 above?

    For Local Lan Server Port and IP information. The local IP Address of the device running NoMachine i.e. 192.168.x.x?

    For starting and ending ports 4000? (Although could be set to another port)

    For Protocol both TCP and UDP?

    For Optional Settings in 2 above

    Starting and Ending RG WAN Port 20580?

    For Remote IP Address the External IP address of the remote device running nxserver?

    I finally see the gateway port 20580 but if I try to update from 4.4.12 the gateway port disappears and if I try to enable it I get the failed to map gateway port. 4.4.12 is the version in my Linux distros package manager. I’m going to purge this and try the latest install direct from the NoMachine website and see what happens.

     

     

     

    #11335
    Avatarkroy
    Contributor

    We strongly recommend to upgrade NoMachine to the newest version.

    For the router configuration. In “Enter IP Address” section write yours machine local IP. In “Starting/Ending Port” enter 4000. In “Protocol” choose TCP (or “ALL” if there is such possibility) and confirm changes (probably you need to restart router after all). Now you should be able to connect from external network. In NoMachine player enter Public IP (not local) and choose Port 4000 and Protocol NX.

    #11342
    AvatarRed Bow Tie
    Participant

    In NoMachine player enter Public IP (not local) and choose Port 4000 and Protocol NX.

    As I use ddns service (changing external IP address) can I use hostname instead of external IP address?

    #11351
    Avatarkroy
    Contributor

    Yes. If it is DDNS hostname you can use it instead of the external IP address.

    #11459
    Avataroleg
    Participant

    Hi,

    I have installed free version of NoMachine 5.1.26 on Raspberry Pi 3b running Raspbian Jessie and want to set up remote access to NX Server when the server is behind a NAT router. I enabled UPnP mapping on my Cisco EPC 3825 router and checked that the line “EnableUPnP NX” in the /usr/NX/etc/server.cfg is not commented. After booting OS Rasbian there is not public IP address on NoMachine’s Welcome Screen page IP list. I checked the status /usr/NX/bin/nxserver –status and everything is enabled  NX> 161 Enabled service: nxserver. NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd. Public IP address appears on the welcome  page after I run /usr/NX/bin/nxserver –restart. NoMachine Preferences->Services Start automatic services at startup is checked. How to let NoMachine to get public IP immediately after booting OS.

     

    #11476
    Avatarkroy
    Contributor

    The time it takes to get public IP information depends on the router.

    Can you do some test? After booting the OS, please run a terminal and execute the command sudo /etc/NX/nxserver --upnpstatus a few times. If nothing shows up in your terminal after 15 minutes, but only shows up after nxserver restart, we need to investigate by looking in the logs.

    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT04M00076.

    Please send them to forum[at]nomachine[dot]com making sure to reference the topic.

    #11488
    Avatarkroy
    Contributor

    In the logs which you sent we can see two different IP numbers to the ones that you indicated in your comments with the logs. We have some additional questions to the problem.

    – Do you have dynamic external IP?

    – How many routers are connected to your network? And – do you connect also other routers to your RPi3 during that test? (because there are two different IPs in logs)

    – On RPi3 are you connected to wifi or ethernet?

    – Do you have some firewall, blockades, etc. on your router configured?

    #11497
    Avataroleg
    Participant

    – The router DHCP Server is enabled. Even though lately external IP is the same I think I have dynamic external IP.

    – I have one router at home. I do not have any other routers. I tried using NoMachine client on my Windows 10 notebook to connect to the RPi3. If I remember right notebook got the same address as RPi3 before and RPi3 got different address.

    – RPi3 was connected to the router via wifi.

    – I have firewall enable checked on my router. As it is said in the manual it means SPI Firewall Protection enabled. It blocks Denial of Service (DoS) attacks. All other sub items on the firewall page are unchecked.

    If you tell what should I do exactly, I can repeat the test and send updated logs to you.

    #11530
    Avatarkroy
    Contributor

    Can you do some test?

    – please run debug on both machines (Rpi3 and your notebook) and restart nxserver. Both machines should be connected to the same router;

    – check external IP on both machines by the same way you just did earlier;

    – now check if ./nxserver –upnpstatus shows the same IP (on both computers and command won’t show nothing please wait few minutes and re-check);

    – try to connect via NoMachine to that external IP and port;

    If you couldn’t connect please disable firewall and other blockades on the router. Restart router and repeat all the steps. In case of issues please send logs from both machines (https://www.nomachine.com/DT07M00098, and send them to forum[at]nomachine[dot]com)

Viewing 12 posts - 1 through 12 (of 12 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.