No external IP, impossible to create gateway port

Forums / NoMachine for Windows / No external IP, impossible to create gateway port

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #27185
    AvatarApo
    Participant

    Hi,

    I installed NoMachine free 6.9.2_1 on two Windows 10 PC’s and one iMac 10.8.4 on my local network – they see each other and everything is fine locally. The problem is that none of them shows an external IP. I tried many things on my router, with UPnP activated : no port mapping, or port mapping as mentioned in AR11L00827, the result is allways the same.

    If I click on “configure” of NX in the network services and ask a gateway port for service port 4000 with indicated port 21292, a messages tells me “Echec de relevé du port sur passerelle”, which means that there is an error with this port on the gateway.

    I also tried to disactivate UPnP on my router with port mapping as mentioned above, the result is still the same : no external IP.

    My router is a Freebox Revolution (France).

    So I decided to collect the logs as described in DT10O00162#1, doing the following : 1) logrotate 2) enable all debug 3) upnpmap 4) upnpstatus 5) provoke the additionnal error by asking a gateway port for service port 4000 with indicated port 21292 6) collect logs.

    “upnpmap” and “upnpstatus” show my external IP, but no port with wich somebody could connect.

    When I reproduced this problem to give you the logs, the Windows 10 I used was connected directly to the router by RJ45-cable. There was no mapping on the router, only UPnP enabled.

    Earlier today I tried to install NoMachine at somebody elses house : everything worked fine right from the beginning and I could connect to that persons Mac through NoMachine from my PC at my home. But it was not possible from this persons to me. So there must be something on my router, but what can I do more ?

    Here’s the details of my commands, and attached the logs and a screenshot of my port mapping :

    C:\WINDOWS\system32>cd C:\Program Files (x86)\NoMachine\bin

    C:\Program Files (x86)\NoMachine\bin>nxserver –logrotate

    NX> 900 Starting log rotation procedure.

    NX> 900 Created compressed file ‘C:\ProgramData\\NoMachine\\var\\log\\logrotate\\nxserver.log-2020.05.05-22.01.11.gz’.

    NX> 900 Log rotation procedure for ‘nxserver.log’ has finished successfully.

    NX> 900 Created compressed file ‘C:\ProgramData\\NoMachine\\var\\log\\logrotate\\nxerror.log-2020.05.05-22.01.11.gz’.

    NX> 900 Log rotation procedure for ‘nxerror.log’ has finished successfully.

    NX> 900 Created compressed file ‘C:\ProgramData\\NoMachine\\var\\log\\logrotate\\nxd.log-2020.05.05-22.01.11.gz’.

    NX> 900 Log rotation procedure for ‘nxd.log’ has finished successfully.

    NX> 900 Created compressed file ‘C:\ProgramData\\NoMachine\\var\\log\\logrotate\\nxservice.log-2020.05.05-22.01.11.gz’.

    NX> 900 Log rotation procedure for ‘nxservice.log’ has finished successfully.

    C:\Program Files (x86)\NoMachine\bin>nxserver –debug –enable all

    NX> 900 Debug mode enabled for: server

    NX> 900 Debug mode enabled for: node

    NX> 900 Debug mode enabled for: agent

    C:\Program Files (x86)\NoMachine\bin>nxserver –upnpmap

    Local IP                   192.168.0.33

    Gateway IP                 192.168.0.254

    External IP                91.165.xx.xx (replaced numbers by xx for anonymity)

    C:\Program Files (x86)\NoMachine\bin>nxserver –upnpstatus

    Local IP                   192.168.0.33

    Gateway IP                 192.168.0.254

    External IP                91.165.xx.xx (replaced numbers by xx for anonymity)

    C:\Program Files (x86)\NoMachine\bin>nxserver –debug –collect

    NX> 900 Procedure to collect logs started.

    NX> 900 Creating log archive.

    NX> 900 Log archive succesfully created.

    NX> 900 Archive is: C:\ProgramData\\NoMachine\\var\\log\\archives\\NoMachine-log-2020.05.05-22.03.36.zip

    NX> 900 Procedure to collect logs finished successfully.

    C:\Program Files (x86)\NoMachine\bin>

    #27340
    AvatarBritgirl
    Keymaster

    Maybe your router does not support UPnP – this is why UPnP doesn’t show up. You could try port forwarding. We looked for an article in English for that specific router on how to enable port forwarding correctly but couldn’t find a good one. Perhaps you are able to find one in French?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.