No external IP on free install Ubuntu 16.04

Forums / NoMachine for Linux / No external IP on free install Ubuntu 16.04

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #16061
    Avatarmgibbons
    Participant

    Hello,

    I’ve installed NoMachine_5.3.12_10_amd64.deb. The NoMachine server displays nx://192.168.200.99 and ssh://192.168.200.99 but no external connection

    I’m behind a NAT with my internal ip being 192.168.200.99. Connections across my internal LAN work flawlessly. The NoMachine server has configured my router as connection to ip 192.168.200.101

    1 NoMachine 24004 TCP 4000 192.168.200.101 Enabled

    Why ip 192.168.200.101? I’ve restarted the server several times to no avail. I’ve also read the doc about NAT Installation.

    I’ve read everything relevant I can find on these forums and the larger internet but have not been able to resolve this. If I try to connect to my external ip nx://xxx.xxx.xxx.133 I get connection refused.

    How can I get an external connection working?

    Thank you

    #16070
    Avatarkroy
    Contributor

    You have double NAT networking, so NoMachine has to go through two routers. The first one which is facing the internet, and the second, which is on your local network. You need to set up separate port forwarding rules on each device.

    Why ip 192.168.200.101?

    It looks that is your second router IP and port 24004 is set for UPnP connection. To connect to the machine from external network you need to configure first router. In your case open 24004 port for 192.168.200.101. Now connection to external IP with port 24004 should work.

    #16099
    Avatarmgibbons
    Participant

    I’m wondering why you say I have double NAT networking. I have only 1 router and no firewall on my Ubuntu desktop.

    #16103
    AvatarTom
    Participant

    Hello,
    We thought about two routers, because you wrote about IP 192.168.200.101 and another IP x.x.x.133

.

    Now we understand that your NoMachine Server ( computer you want to connect to ) IP is  192.168.200.99. Router has internal IP 192.168.200.101 and you have external IP x.x.x.133.

    If this line “1 NoMachine 24004 TCP 4000 192.168.200.101 Enabled” show me set forwarding port 24004 on your router please change this to IP  192.168.200.99.  Router must forward traffic on port 24004 to your computer IP.

    Please remember that on computer with you want connect you must set in connection IP x.x.x.133 and port 24004.

    Regards
    Tom

    #16113
    Avatarmgibbons
    Participant

    What I was trying to say in my first post is that it was NoMachine that set the router to forward to IP 192.168.200.101 on installation despite my internal ip being IP 192.168.200.99. This seems like a bug in NoMachine.

    #16188
    Avatarkroy
    Contributor

    Please enable debug (uncomment and set SessionLogLevel 7 in the /usr/NX/etc/server.cfg), restart nxserver (sudo /usr/NX/bin/nxserver --restart) tar logs (it’s in the /usr/NX/var/log/) and send them to forum[at]nomachine[dot]com.

    Send also output of the commands: sudo /usr/NX/bin/nxserver --upnpstatus and ifconfig -a.

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.