No hash(#) symbol input on iPad magic keyboard

Forums / NoMachine for Mobile / No hash(#) symbol input on iPad magic keyboard

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #40120
    cocoa117
    Participant

    Has anyone notice on the iPAD magic keyboard (UK version), you can’t type # on the Ubuntu remote server?

    NoMachine client version: 6.1.9

    iPad OS version: 15.6.1

    NoMachine server version: 6.18.1

    Ubuntu remote version: 22.04.1

    On the Ubuntu remote, I setup keyboard mapping in both English(UK) and English(UK, Macintosh). I have tried both

    1. when you choose English(UK), it’s basically PC keyboard map. The iPad magic keyboard’s key works, but don’t match the local keyboard mapping.

    2. when you choose English(UK, Macintosh), the # and € key. Those two keys requires you use right hand side option + 3 or 2 to type in, but when I type it I got arg 3 output from terminal.

    The terminal is from GNOME desktop -> Terminal.

    When I use NoMachine Mac client connect to the same server, English(UK, Macintosh) key map works out of box.

     

    Any ideas?

    #40310
    Britgirl
    Keymaster

    Both Android and iOS have symbols which don’t exist in the corresponding X11 maps. That said, the next release will provide some improvements to how keyboard is handled when connecting from mobile devices. Keep your eyes open for that 🙂

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.