No login screen with Ubuntu Gnome 13.10

Forums / NoMachine for Linux / No login screen with Ubuntu Gnome 13.10

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1954
    carsten.heidmann
    Participant

    I try to login from a Windows 7 client to a Ubuntu Gnome 13.10 host (console) without a keyboard/mouse/monitor attached. The connection succeeds but I only get a blank grey screen without login possibility. The Nomachine version on the server is the newest one available. The server itself is alive and healthy which I can confirm through SSH login.

    #1973
    simonguerrero
    Participant

    Yes, exactly the same for me. This system used to work fine with freenx server over ssh.

     

    I’ve tried all the recommended settings for ~/.vnc/xstartup on various sites, but I’ve had no joy. Help!

    #2010
    Britgirl
    Keymaster

    @carsten.heidmann did you follow the instructions here? https://www.nomachine.com/AR10K00710

    Or is it a normal installation running Ubuntu dekstop (LightDM/Unity)?

    @simonquerrero  NX Free Edition was a terminal server and supported SSH.

    If you want those functionalities, you need the Workstation for Linux.

    #2031
    carsten.heidmann
    Participant

    Hi Рthis is a normal installation running Ubuntu GNOME flavor with gdm as display manager. It ist not a headless system РI only try to run it without a monitor attached. I just reinstalled everything and right now I am experiencing the behaviour, that I get a login screen with Nomachine from remote when I leave the monitor attached. Running the machine without monitor I do not get a login screen from remote. It seems that this may be a problem with the graphics configuration  being unable to run without an attached monitor Рbut maybe you have suggestions on this?

    #2035
    fra81
    Moderator

    Yes, it looks like the graphics card stops working when detaching the monitor.

    You can take a look at this article for a way to workaround this problem.

    https://www.nomachine.com/AR10K00710

    #2095
    carsten.heidmann
    Participant

    OK – my problem is solved. This had nothing to do with NoMachine NX. The graphics card in the machine just stops working when no monitor is attached, which can be ok for a desktop computer (although I find it difficult to think of a reasonable scenario where one would deattach the monitor for a longer time in a desktop environment…). I used this solution to build a dummy monitor plug with 3x 68 Ohm resitors and I have the X-Environment up and runnning!

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.