No prompt when connecting to NoMachine node

Forums / NoMachine for Linux / No prompt when connecting to NoMachine node

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42425
    merrittr
    Participant

    I we have one node that has NoMachine on it  and when people authenticate they are allowed in without prompting the user actually logged in on the machine to allow it …how do I change that?

    #42446
    Britgirl
    Participant

    By default all desktop sharing connections must be explicitly accepted to proceed, but I don’t know if you perhaps changed something on the server side.

    How are those users authenticating? With different system accounts or are they all sharing the same login as the owner of the desktop who is already logged in?

    On the server machine, go to Server settings -> Security -> User acceptance and check which boxes are enabled. You will see:

    1) Don’t require acceptance if the user logged in as system user (by default the box is empty)

    By enabling/ticking that box, users with a valid account on this host can connect without the need of the desktop owner’s approval. This configuration is suitable for unattended computers.

    2) Don’t require acceptance if the user logged in as the owner of the desktop (by default the box is ticked)

    If all users connecting are using the same account as the owner (e.g everyone connects using the name “myteam”) and you want everyone connecting to be authorised by the owner already connected, you must leave this box empty.

    If you have Workstation installed (so NoMachine virtual Linux desktops are supported), there will also be a section for virtual desktops in the same panel:

    Virtual desktops
    Don’t require acceptance if the user logged in as a system user(empty/disabled by default)

    Don’t require acceptance if the user logged in as the owner of the desktop (enabled by default)

    More about this is available in the relative guide:

    https://kb.nomachine.com/DT07S00237#2.5

    Perhaps you can attach a screenshot of of the “User acceptance” section in the Security settings panel of the server?

     

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.