No sound from Catalina

Forums / NoMachine for Mac / No sound from Catalina

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #23664
    Avatartyl
    Participant

    Hi,

    I was able to successfully enable the nxaudio module in macOS Catalina, and the microphone and audio adapter appear. However, I get no sound out of them when streaming from NoMachine to another device. I can see that the levels are moving while sound is playing, so NoMachine is picking up the sound, but it isn’t passing it to the other device.

    Both nxaudio and the whole NoMachine application are added under Security and Privacy->Accessbility. The microphone is also enabled. I have tried the iOS, Ubuntu, and Windows clients and none of them will stream the sound.

    Today’s update does not solve the issue.

    #23712
    Avatarmkub
    Participant

    Hi,

    The problem is caused by the bug in the macOS Catalina Beta. For now, it is impossible to stream audio from this operating system. However, if you want to use NoMachine as a Client and stream audio from other machines you can use workaround. Open terminal and type:

    /Applications/NoMachine.app/Contents/MacOS/nxplayer and then establish connection to the desired machine. Audio should work properly.

    #23725
    Avatartyl
    Participant

    Heya, thank you very much 🙂 I’ll give it a go. I was trying to do that the other day actually.

    Also, just to add: today’s beta build doesn’t fix it either. I wonder what causes it?

    #23733
    Avatarmkub
    Participant

    Probably, there are some problems with granting appropriate permissions.

    Thanks,

    mkub

    #24473
    AvatarBritgirl
    Keymaster

    Please update to the latest release for Mac, NoMachine 6.8.2.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as closed, you can't post.