No sound on Linux

Forums / NoMachine for Linux / No sound on Linux

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #26662
    Avatarwxl
    Participant

    At some point in the recent past, I was not able to transmit sound from the server to the client, though that has worked in the past. I have not really needed it, but working from home now, my whole setup is different and I need audio notifications from the server.

    There’s nothing particular remarkable about the sound configuration of either machine, so just default Pulseaudio configs. On the server, in pavucontrol, I can see the NoMachine Output (Virtual Stream) is default and if I play something, I can see the meter bouncing appropriately away. Nothing on the other end of things. I’ve toggled muting the server on and off to no avail. Sound works find on the client, though. I’m not sure if I should expect to see a different Playback stream, but I don’t.

    • Client
      • Lubuntu 18.04
      • NoMachine 6.9.2-3
      • snd_hda_intel kernel module
      • 8086:9d71 device
    • Server
      • Kubuntu 18.04
      • NoMachine 6.9.2-3
      • snd_hda_intel kernel module
      • 8086:3b56 device
    #26800
    Avatarwitek
    Participant

    Hi,

    Can you please check the following things on the server side while using NoMachine and playing something?

    1. Run the following command in the terminal and paste or attach the output in your reply:

    pactl list sinks

    2. In “Recording” tab of pavucontrol you can see that NoMachine application is recording audio from some source. What is the name of this source?

    3. You can also look into pulseaudio logs and check if there are some error/warning logs. By default you can find them in “/var/log/syslog”. Please run the following command in the terminal and attach the file “pulseaudio.log” in your reply.

    cat /var/log/syslog* | grep -i pulse > /tmp/pulseaudio.log

    #26826
    Avatarwxl
    Participant

    Ok so I was playing off of Bandcamp.

    1. Attached.

    2. There are two “Applications,” “NoMachine: NoMachine” and “NoMachine: NoMachine Stream,” both of which say they’re from “Monitor of NoMachine Output.”

    3. Nothing. FWIW usually older logs are gzipped, so I zcatted those, too.

    Attachments:
    1. sinks.txt
    #27000
    Avatarwitek
    Participant

    Sorry for the late response. We were trying to reproduce this problem but we could not.

    I need to ask more questions to investigate the problem.
    Before that, please restart the PulseAudio server on Kubuntu machine using the command bellow:

    pulseaudio -k; pulseaudio -D; sudo /etc/NX/nxserver --restart

    1. When you are connected to the host via NoMachine, what is the default sink and source on the server? You can check this with the following command:

    pactl info | grep Default

    2. From the provided list I can see that all nx sinks are created properly but “Simultaneous output to NoMachine Output” is not in the “RUNNING” state. It should be set to the default sink by the NoMachine and because of that, applications like Firefox should play on this sink. You can check if applications are using correct default sink in the “Playback” tab of pavucontrol.

    Also debug logs will be helpful in this case. How to do it you can find here:

    https://www.nomachine.com/DT10O00163#1.1

    and please send the logs archive to forum[at]nomachine[dot]com.

    #27757
    Avatarwxl
    Participant

    Well, the problem has gone away. I’m now on 6.10.12-1. I do notice that lots of things are different now. Not only does the sound work but my Compose key is working again and my lock screen has the right theme (before it was kind of generic). I wonder if it was not some error with how the session was created. Perhaps when trying to connect to the old session, it failed and created a new one, but the old one was still there. I have no clue, honestly. Sorry for troubling you.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.