No text showing in client sceen under Xorg KDE

Forums / NoMachine for Linux / No text showing in client sceen under Xorg KDE

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #36708
    pnunn
    Participant

    For some reason under X the NoMachine client doesn’t show any text at all.

    Seems to be fine under Wayland (most things are the other way around 🙂  ).

    Screen shot is attached.

     

    #36714
    Britgirl
    Keymaster

    The image attached but is empty. Can you submit it again, please?

    #36717
    pnunn
    Participant

    sorry about that..

     

    Attached.. but I can see the preview..??

    #36721
    Britgirl
    Keymaster

    I managed to recuperate it and added it to your original topic. Sorry for the hassle 🙂

    Can you tell me what Linux distribution and version this is?

    #36724
    pnunn
    Participant

    Thanks @Britgirl the distro is kde neon.

    I was using Wayland and everthing worked as far as NoMachine was concerned, but for other reasons I’ve had to switch back to X and now its not 🙂

     

    Peter.

    #36740
    Britgirl
    Keymaster

    Strange problem and not one we have seen in our tests.

    Open a terminal on the affected host execute ‘xdpyinfo’ and ‘xrdb -query -all’ . What’s the output?

    If you change the font in the NoMachine Player settings, does the problem go away?

    #36757
    pnunn
    Participant

    OK, so this is embarrasing.

    I have no clue why, I’ve applied some updates, I’ve made some minor changes to my xrandar config, and I just checked and its working fine now.

    It was consistently broken, now consistently fixed.

    Thanks for the support.  Thanks for the interest.

    But, I guess this can be closed.

    Peter.

    #36761
    Britgirl
    Keymaster

    So this was most likely to do with your system’s configuration, and not something broken in NoMachine. Thanks for letting us know.

    #37052
    rblb
    Participant

    I am having the same issue. Could you say what you’ve changed? @pnunn

    #37070
    pnunn
    Participant

    @rblb I wish I could tell you.

    I switched between Xorg and Wayland and was seeing the problem again for a day or so, but after a reboot, still in the Wayland session, its resolved itself again.

    I’m really not sure what the issue is.

    (I did set the locale on the machine, which wasn’t set correctly, it could have been that come to think of it).

     

    Peter.

Viewing 10 posts - 1 through 10 (of 10 total)

This topic was marked as closed, you can't post.