No USB redirection on Ubuntu 18.04

Forums / NoMachine Terminal Server Products / No USB redirection on Ubuntu 18.04

This topic contains 1 reply, has 2 voices, and was last updated by Avatar Giorgi-G. 1 month, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #23937
    Avatar
    VladimirSokolov
    Participant

    Hello! I installed ‘nomachine-terminal-server_6.8.1_1_amd64.deb’ on desktop, but usb forwarding does not work …
    I found an article describing a solution to this problem https://www.nomachine.com/AR12J00658. After installing linux headers, I run make but still get errors …

    make -C /lib/modules/5.0.0-31-generic/build M=/usr/NX/share/src/nxusb
    make[1]: Entering directory ‘/usr/src/linux-headers-5.0.0-31-generic’
    arch/x86/Makefile:146: CONFIG_X86_X32 enabled but no binutils support
    CC [M]  /usr/NX/share/src/nxusb/nxusb-vhci-hcd.o
    /usr/NX/share/src/nxusb/nxusb-vhci-hcd.c:1396:1: fatal error: opening dependency file /usr/NX/share/src/nxusb/.nxusb-vhci-hcd.o.d: Permission denied
    module_exit(cleanup);
    ^~~~~~~~~~~
    compilation terminated.
    scripts/Makefile.build:284: recipe for target ‘/usr/NX/share/src/nxusb/nxusb-vhci-hcd.o’ failed
    make[2]: *** [/usr/NX/share/src/nxusb/nxusb-vhci-hcd.o] Error 1
    Makefile:1608: recipe for target ‘_module_/usr/NX/share/src/nxusb’ failed
    make[1]: *** [_module_/usr/NX/share/src/nxusb] Error 2
    make[1]: Leaving directory ‘/usr/src/linux-headers-5.0.0-31-generic’
    Makefile:8: recipe for target ‘all’ failed
    make: *** [all] Error 2

    viewadmin@ubuntu:/usr/NX/share/src/nxusb$ uname -a
    Linux ubuntu 5.0.0-31-generic #33~18.04.1-Ubuntu SMP Tue Oct 1 10:20:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    #23956
    Avatar
    Giorgi-G.
    Contributor

    Hello!

    Did you follow the instruction about running make under su, not just “sudo make” ?

    Additionally, looks like binutils is missing on your system and needs to be installed.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.