NodeLoginGreeting not working

Forums / NoMachine Terminal Server Products / NodeLoginGreeting not working

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #33089
    Avatarpbisbal
    Participant

    I am using NoMachine Enterprise Terminal Server 7.4.1.  on CentOS 7 x86_64. We have NVIDIA Quadro RTX 6000 GPUs, so I followed the instructions for setting up VirtualGL here:

    https://knowledgebase.nomachine.com/AR04Q01024

    After following those instructions, I have NoMachine up and running using hardware acceleration.

    My DefaultDesktopCommand and CommandStartGnome are as follows:

    DefaultDesktopCommand "/bin/dbus-launch --exit-with-session gnome-session --session=gnome --disable-acceleration-check"
    CommandStartGnome "/bin/dbus-launch --exit-with-session gnome-session --session=gnome --disable-acceleration-check"

    We’re required to have a warning message displayed whenever someone logs in to one of our systems. It’s a multi-line message. It appears that when I try to include a multiline message for NodeFirstLoginGreeting and NodeLoginGreeting, it doesn’t work. Can anyone confirm this, or tell me how to get a multiline message for my greeter?

    Also, it would be preferable for this message to be displayed *before* someone logs into a NoMachine session. Is that possible?

    Thanks,

    Prentice

    #33188
    Avatarkroy
    Contributor

    Hi,

    You can try the new line sequence “\n”, for example:

    NodeLoginGreeting “Hello\nWelcome to your NoMachine session\nHow are you today?”

    Also, it would be preferable for this message to be displayed *before* someone logs into a NoMachine session. Is that possible?

    Check node.cfg key: UserScriptBeforeSessionReconnect. More info about user scripts you can find there: https://knowledgebase.nomachine.com/AR02L00787

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.