NoMachine 4.6.4 PAM problem

Forums / NoMachine for Linux / NoMachine 4.6.4 PAM problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7475
    iceback
    Participant

    On rhel6.6 I just rolled in NoMachine_4.6.4_16_i686.rpm with rpm –upgrade

    purity:NX$ whoami

    u0138544

    purity:NX$ sudo bin/nxserver –userauth u0138544

    NX> 139 NX user DB is: off

    NX> 139 NX password DB is: off.

    NX> 139 Authentication for user: u0138544 is: system.

    nxserver.log

    2015-06-12 18:09:13 412.771 27129 NXSERVER Starting NoMachine server 4.6.4 and services.

    2015-06-12 18:09:28 719.991 27407 NXSERVER ERROR! Error while trying to authenticate user: u0138544. NXNssUserManager::auth returned 1

    2015-06-12 18:09:28 720.224 27407 NXSERVER ERROR! wrong ‘nxexec authentication’ for user ‘u0138544’ from ‘10.77.0.55’.

    2015-06-12 18:09:37 268.532 27425 NXSERVER ERROR! Error while trying to authenticate user: u0138544. NXNssUserManager::auth returned 1

    2015-06-12 18:09:37 268.735 27425 NXSERVER ERROR! wrong ‘nxexec authentication’ for user ‘u0138544’ from ‘10.77.0.55’.

    nxerror.log

    Info: Handler with pid 27407 terminated on Fri Jun 12 18:09:28 2015.

    Info: Handler started with pid 27425 on Fri Jun 12 18:09:29 2015.

    Info: Handling connection from 10.77.0.55 port 54525 on Fri Jun 12 18:09:29 2015.

    nxexecPAMOpen: PAM library not found.

    nxexecPAMOpen: Error: ‘libpam.so.0: cannot open shared object file: No such file or directory’.

    nxexecCheckCredentials: No match for pwd.

    Info: Connection from 10.77.0.55 port 54525 closed on Fri Jun 12 18:09:37 2015.

    Info: Handler with pid 27425 terminated on Fri Jun 12 18:09:37 2015.

    Info: Handler started with pid 27444 on Fri Jun 12 18:09:37 2015.

    Info: Handling connection from 10.77.0.55 port 54526 on Fri Jun 12 18:09:37 2015.

    I even symlinked /usr/lib/libpam.so (and pam_misc) into /usr/NX/lib

    #7499
    iceback
    Participant

    The client is a mac OSX 10.10.2 with version 4.4.1

    I can connect to other machines at same center. They have not been upgraded to 4.6

     

     

    #7515
    bakhtadze
    Participant

    Hello

    Please can you run this command: ldconfig -p | grep libpam*

    This command will help us to find what pam libraries are installed on your machine.

    #7522
    iceback
    Participant

    purity:~$ ldconfig -p | grep libpam*

    libpath_utils.so.1 (libc6,x86-64) => /usr/lib64/libpath_utils.so.1

    libparted-2.1.so.0 (libc6,x86-64) => /lib64/libparted-2.1.so.0

    libpaps.so.0 (libc6,x86-64) => /usr/lib64/libpaps.so.0

    libpangoxft-1.0.so.0 (libc6,x86-64) => /usr/lib64/libpangoxft-1.0.so.0

    libpangoxft-1.0.so.0 (libc6) => /usr/lib/libpangoxft-1.0.so.0

    libpangoxft-1.0.so (libc6,x86-64) => /usr/lib64/libpangoxft-1.0.so

    libpangox-1.0.so.0 (libc6,x86-64) => /usr/lib64/libpangox-1.0.so.0

    libpangox-1.0.so.0 (libc6) => /usr/lib/libpangox-1.0.so.0

    libpangox-1.0.so (libc6,x86-64) => /usr/lib64/libpangox-1.0.so

    libpangomm-1.4.so.1 (libc6,x86-64) => /usr/lib64/libpangomm-1.4.so.1

    libpangoft2-1.0.so.0 (libc6,x86-64) => /usr/lib64/libpangoft2-1.0.so.0

    libpangoft2-1.0.so.0 (libc6) => /usr/lib/libpangoft2-1.0.so.0

    libpangoft2-1.0.so (libc6,x86-64) => /usr/lib64/libpangoft2-1.0.so

    libpangocairo-1.0.so.0 (libc6,x86-64) => /usr/lib64/libpangocairo-1.0.so.0

    libpangocairo-1.0.so.0 (libc6) => /usr/lib/libpangocairo-1.0.so.0

    libpangocairo-1.0.so (libc6,x86-64) => /usr/lib64/libpangocairo-1.0.so

    libpango-1.0.so.0 (libc6,x86-64) => /usr/lib64/libpango-1.0.so.0

    libpango-1.0.so.0 (libc6) => /usr/lib/libpango-1.0.so.0

    libpango-1.0.so (libc6,x86-64) => /usr/lib64/libpango-1.0.so

    libpanelw.so.5 (libc6,x86-64) => /usr/lib64/libpanelw.so.5

    libpanelw.so.5 (libc6) => /usr/lib/libpanelw.so.5

    libpanelw.so (libc6,x86-64) => /usr/lib64/libpanelw.so

    libpanelappletmm-2.6.so.1 (libc6,x86-64) => /usr/lib64/libpanelappletmm-2.6.so.1

    libpanel.so.5 (libc6,x86-64) => /usr/lib64/libpanel.so.5

    libpanel.so.5 (libc6) => /usr/lib/libpanel.so.5

    libpanel.so (libc6,x86-64) => /usr/lib64/libpanel.so

    libpanel-applet-2.so.0 (libc6,x86-64) => /usr/lib64/libpanel-applet-2.so.0

    libpamc.so.0 (libc6,x86-64) => /lib64/libpamc.so.0

    libpamc.so (libc6,x86-64) => /usr/lib64/libpamc.so

    libpam_misc.so.0 (libc6,x86-64) => /lib64/libpam_misc.so.0

    libpam_misc.so (libc6,x86-64) => /usr/lib64/libpam_misc.so

    libpam.so.0 (libc6,x86-64) => /lib64/libpam.so.0

    libpam.so (libc6,x86-64) => /usr/lib64/libpam.so

    libpakchois.so.0 (libc6,x86-64) => /usr/lib64/libpakchois.so.0

    libpackagekit-glib2.so.12 (libc6,x86-64) => /usr/lib64/libpackagekit-glib2.so.12

    libpackagekit-glib.so.12 (libc6,x86-64) => /usr/lib64/libpackagekit-glib.so.12

    purity:~$

    #7546
    bakhtadze
    Participant

    Hello
    From the output of your command we can see that your OS is x64 bit architecture.
    The package you have installed is for x32 bit architecture.
    Please remove the current package and install nomachine_4.6.4_13_x86_64.rpm.

    #7548
    iceback
    Participant

    OMG.

    Four upgrades later I grab the wrong rpm.  So sorry for the noise.

    #7590
    Britgirl
    Keymaster

    NP, I will close the topic 😉

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.