NoMachine 4 free edition – nxserver –checkssh returns an error

Forums / NoMachine for Linux / NoMachine 4 free edition – nxserver –checkssh returns an error

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #5779
    jcdole
    Participant

    Hello

    On opensuse 13.1, KDE 4.11.5, NoMachine 4.3.30.1  (free); during install, you try to validate nx user against authorized_keys2 or authorized_keys.

    NX> 700 Running: /bin/cat '/var/NX/nx/.ssh/node.localhost.id_dsa.pub.tmp' >> '/var/NX/nx/.ssh/default.id_dsa.pub'.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/cp -f '/var/NX/nx/.ssh/default.id_dsa.pub' '/var/NX/nx/.ssh/authorized_keys2'.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown nx '/var/NX/nx/.ssh/authorized_keys2'.
    NX> 700 Result: OK.
    NX> 700 Running: '/etc/NX/nxserver' --checkssh.
    NX> 700 Cannot check SSH server keys.
    NX> 700 Running: /bin/rm -f '/var/NX/nx/.ssh/authorized_keys2'.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/rm -f '/var/NX/nx/.ssh/node.localhost.id_dsa.pub.tmp'.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/cp -f '/var/NX/nx/.ssh/default.id_dsa.pub' '/var/NX/nx/.ssh/authorized_keys'.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/chown nx '/var/NX/nx/.ssh/authorized_keys'.
    NX> 700 Result: OK.
    NX> 700 Running: '/etc/NX/nxserver' --checkssh.
    NX> 700 Cannot check SSH server keys.
    NX> 700 Running: /bin/rm -f '/var/NX/nx/.ssh/authorized_keys'.
    NX> 700 Result: OK.
    NX> 700 Running: /bin/rm -f '/var/NX/nx/.ssh/node.localhost.id_dsa.pub.tmp'.
    NX> 700 Result: OK.
    NX> 700 Could not determine authorized_key filename.

    This is useless on the free version. Because “/etc/NX/nxserver –checkssh” return always an error :

    linux:~ # /etc/NX/nxserver --checkssh
    NX> 500 Authentication as user nx using the NX SSH key-pair failed.
    NX> 500 This may be due to the configuration of your SSH server. Please
    NX> 500 ensure that the location and file name of the SSH authorized
    NX> 500 keys is the same in both the SSHD and NX server configuration
    NX> 500 files and that the nx user is listed among the accepted users
    NX> 500 in the SSHD configuration file.
    NX> 161 Enabled service: nxserver.
    linux:~ #

    In sshd log we found a “disconnected by user” message :

    debug1: Forced command (key option) '/etc/NX/nxserver --login'
    debug1: Received SIGCHLD.
    debug1: session_by_pid: pid 6311
    debug1: session_exit_message: session 0 channel 0 pid 6311
    debug1: session_exit_message: release channel 0
    Received disconnect from 127.0.0.1: 11: disconnected by user
    debug1: do_cleanup
    debug1: do_cleanup

    and in nxserver.log we found a “900: SSH connections are not supported on this server.” message :

    2014-12-20 16:08:40 811.332  6447 NXSERVER handleSIGCHLD
    2014-12-20 16:08:40 811.435  6447 NXSERVER handleSIGCHLD checking child: 6469
    2014-12-20 16:08:40 934.444  6447 NXSERVER nx client: received '58' byte/s in stdout
    2014-12-20 16:08:40 934.631  6447 NXSERVER nx client: parsing response buf
    2014-12-20 16:08:40 934.735  6447 NXSERVER nx client: received message n. '900': 'SSH connections are not supported on this server.'
    2014-12-20 16:08:40 934.855  6447 NXSERVER nx client: skipping debug message: 'SSH connections are not supported on this server.'
    2014-12-20 16:08:40 936.895  6447 NXSERVER nx client: STDOUT was closed
    2014-12-20 16:08:40 937.081  6447 NXSERVER NXClose FD#8 from NXServer2Server::execute.
    2014-12-20 16:08:40 937.207  6447 NXSERVER NXClose FD#9 from NXServer2Server::execute.
    2014-12-20 16:08:40 937.942  6447 NXSERVER NXParser: signal 'CHLD' received.
    2014-12-20 16:08:40 938.102  6447 NXSERVER Received 'SIGCHLD' signal:going to handle it
    2014-12-20 16:08:40 938.204  6447 NXSERVER handleSIGCHLD
    2014-12-20 16:08:40 938.304  6447 NXSERVER handleSIGCHLD checking child: 6469
    2014-12-20 16:08:40 938.522  6447 NXSERVER Process (6469) finished with exit status '1'.
    2014-12-20 16:08:40 938.654  6447 NXSERVER Going to call NXProcessRemove(6469)
    2014-12-20 16:08:40 939.031  6447 NXSERVER Removed '6469' from children list.
    2014-12-20 16:08:40 939.270  6447 NXSERVER nxdefaultExitCodeHandler: process with pid 6469 just died with exit code '1'.
    2014-12-20 16:08:40 939.511  6447 NXSERVER nx client: finished with errors, last msg from server was -1:
    2014-12-20 16:08:40 939.953  6447 NXSERVER Sent response message 'NX> 500 Authentication as user nx using the NX SSH key-pair failed.\nNX> 500 This may be due to the configuration of your SSH server. Please\nNX> 500 ensure that the location and file name of the SSH authorized\nNX> 500 keys is the same in both the SSHD and NX server configuration\nNX> 500 files and that the nx user is listed among the accepted users\nNX> 500 in the SSHD configuration file.'
    2014-12-20 16:08:40 940.380  6447 NXSERVER Sent response message 'NX> 161 Enabled service: nxserver.'
    2014-12-20 16:08:40 940.667  6447 NXSERVER Finalize process.
    2014-12-20 16:08:40 941.117  6447 NXSERVER NXClose FD#3 from NXBegin::finalizeProcess.

    So we could not test if installation is OK.

    Any help is welcome

    #5792
    zaq
    Contributor

    Hello,

    The free version of NoMachine doesn’t support SSH connections. You should check point 1.3 of the installation guide:

    https://www.nomachine.com/DT09K00056

    This is why ‘nxserver –checkssh reports an error. This is used by other NoMachine products, which support the SSH protocol.

    Instead of using ‘nxserver –checkssh’ to verify your installation you can use:

    /etc/NX/bin/nxserver –status

    The output of the command should be:

    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.

    In the case of NoMachine (free), ‘–checkssh’ is unnecessary but harmless. We will remove it.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.