NoMachine 5.1.44 reset X server

Forums / NoMachine for Linux / NoMachine 5.1.44 reset X server

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #12013
    maxchendt
    Participant

    Local: NoMachine 5.1.44, Ubuntu 14.04.5, 4.4.0-31-generic, Mate desktop, 1920×1200

    Remote: NoMachine 5.1.44, Ubuntu 16.04.1, 4.4.0-31-generic, Mate desktop, 1366×768

    I am testing Ubuntu 16.04, NX windows fit the remote server, restart U16.04 through NX, do nothing locally, after a few seconds, the X server in the local computer will be reset (like an ctlr-alt-bksp was press).

    I reboot U14, NX to U16,   test again, say restart U16 through NX interface windows, do nothing, the X in U14 reset after a few seconds

    #12032
    Britgirl
    Keymaster

    Have you checked the box ‘Grab the keyboard input’  (first checkbox on the right in Input section of Player settings)?

    https://www.nomachine.com/DT11M00106#2.1.

    #12040
    maxchendt
    Participant
    #12056
    Britgirl
    Keymaster

    Check the box. What happens?

     

    #12076
    maxchendt
    Participant

    weird, with or without check, both will randomly reset local X.

    #12094
    kroy
    Contributor

    It looks like your local X server crashes. Can you reproduce the problem and send to forum[at]nomachine[dot]com or attach here Xorg.0.log and Xorg.0.log.old? You can find it in /var/log/ on your local machine.

    #12131
    maxchendt
    Participant

    attached

    Yeah, crash, and return to login screen. I am suffering, for some of my jobs are not save, and my VirtualBox VMs (GUI, not headless) abort.

    #12139
    Britgirl
    Keymaster

    Please send the logs to forum[at]nomachine[dot]com.

    #12173
    kroy
    Contributor

    Unfortunately, there is no any crash in the logs. Can you check if you have some crash report or core files (generated when issue had happen) in your home directory or in the /var/crash folder?

    We still weren’t able to reproduce problem. Have you tried reversing sides? Does the problem appear also if you connect from Ubuntu 16 to Ubuntu 14?

    #12209
    maxchendt
    Participant

    no crash report, no core files.

    It happens randomly (not every time), if restart remote host through NX and do nothing locally.

    Thus, I close NX, and restart remote host through SSH.

    #12261
    kroy
    Contributor

    You need to configure the system on client side to get a backtrace from the crashes. For example you can use this instruction: https://wiki.ubuntu.com/DebuggingProgramCrash. Try to reproduce problem and send backtrace to forum[at]nomachine[dot]com.

Viewing 11 posts - 1 through 11 (of 11 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.