NoMachine 7.4.1 keeps restarting upon connection

Forums / NoMachine for Mac / NoMachine 7.4.1 keeps restarting upon connection

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #32745
    basstie
    Participant

    I am facing an issue on the remote machine (3 physical displays) with the latest update of NoMachine 7.4.1 (free version) on MacOS Mojave 10.14.6.
    Regardless of whether I try to connect to the remote computer on a local network or through the internet, the NoMachine service keeps cyclically switching off and on upon establishing a connection. On the remote computer, it even makes the NoMachine icon disappear from the status menu for a number of seconds.
    I tried connecting from Windows 10, MacOS Catalina 10.15.3 and MacOS Big Sur 11.2.3 (all 7.4.1 free version) with the same issues showing either white or black screen.
    Anyone else having the same issue?

    #32782
    Carin
    Participant

    Hi basstie,

    Can you send us logs from the server-side, please? You can see the following article for guidance: Collect server and client logs manually.

    Please send them as an attachment to forum[at]nomachine[dot]com making sure you use the title of the topic in the subject of your email. Thanks!

    #33930
    Carin
    Participant

    Hi basstie,

    We received your logs and it looks like the nxnode crash often, locally.
    Can you please check if there are crash reports available in the directory: /Users/(username)/Library/Logs/DiagnosticReports/

    These are the files with a ‘.crash’ suffix. Can you please send them to us? Thanks!

    #34131
    Carin
    Participant

    Hi basstie,

    Thank you for sending the files. We are currently working on a fix.

    In the meantime, we suggest you try a temporary workaround:
    – Insert this line: DisplayServerExtraOptions "-yuvgrab 1" in /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfgand restart the server.

    Please let us know the outcome 😉

    #34136
    basstie
    Participant

    Hi Carin,

    I really appreciate your quick response. For the time being the temporary workaround you suggested works fine.

    Let me add some more info from the previous personal communication we had.
    The issue was still persisting, even on NoMachine 7.6.2 (free version).
    It was easily reproducible in ALL displays mode, immediately after dragging any window across displays.

    #34456
    Carin
    Participant

     

    Hi basstie,

    A Trouble Report has been opened Display server terminates unexpectedly on multi-monitor Mac and you are invited to sign up to the ‘notify me’ tool in order to receive notification of when a fix has been released.
    This thread will eventually be closed.

    #34465
    basstie
    Participant

    Hi Carin,

    thanks for letting me know about opening a trouble report. How exactly shall I sign up to the ‘notify me’ tool you are mentioning?

    #34469
    Carin
    Participant

    Hi basstie,

    Very good question! I am sorry I forgot that we have temporarily removed the ‘notify me’ facility from the Trouble Report and Feature Request sections of the Knowledge Base.
    You can monitor our software update announcements here https://knowledgebase.nomachine.com/software-updates, where we publish the list of fixes. The fix for this Trouble Report should be included in the next update.

Viewing 8 posts - 1 through 8 (of 8 total)

This topic was marked as solved, you can't post.