NoMachine and UFW

Forums / NoMachine for Linux / NoMachine and UFW

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28448
    Avatarpaulgeanta
    Participant

    Going crazy trying to secure my server.  I have NoMachine on a linux box behind a comcast router. I forward the port 4000 on the router to th linux box. Through the linux firewall I only allow port 4000 from a specific outside IP. However when I nmap from a different IP port 4000 is open and available for connections.

     

    Did anyone see anything like this?

     

    Thank you,

    Paul

    #28459
    Avatarreza
    Moderator

    If you want to take control over FW settings please disable automatic FW configuration by changing that key in server.cfg:

    # Enable the server to automatically configure the firewall for all

    # the configured services. On platforms that don’t support adding

    # the specific executables to a white list, the needed ports are

    # added at server startup and removed at server shutdown, or when,

    # at run-time, a new port is needed. The default value is 1.

    #

    # 1: Enabled. NoMachine opens the required ports in the firewall.

    #

    # 0: Disabled. Firewall must be configured manually. By default

    #    the required ports are TCP ports 4000 for NX, 4080 and 4443

    #    for HTTP and UDP ports in the range 4011-4999 range.

    #

    #EnableFirewallConfiguration 1

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.