NoMachine cannot connect remote hard disk

Forums / NoMachine for Mac / NoMachine cannot connect remote hard disk

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #33859
    lottolearn
    Participant

    Hi,

    This started happening a few updates ago

    My server is MacOS, and my client is Windows

    It used to work, but then when I updated earlier this year it stopped.

    When I go to mount, basically my mac hangs on every process running. Even running an ls it hangs

    There’s not much in the logs, but I finally found out an interesting log message

    Jun  2 11:04:01 lottolearn-mac nxnode[13381]: BUG in libdispatch client: mach_recv, monitored resource vanished before the source cancel handler was invoked { 0x7fb7cf9a9280[source], ident: 257795 / 0x3ef03, handler: 0x7fff65097ed1 }

    I tried doing public mount, and moved it to my /Users/Shared where all users can write to, still no luck.

    #33928
    Carin
    Participant

    Hi lottolearn,

    Is there something specific related to the mounted disks (e.g. file system)?

    Can you please send logs to help us with the investigation? For now, server-side logs will be enough. You can collect the logs as described in this article: https://knowledgebase.nomachine.com/DT10O00163#1.3  

    Please submit them to forum[at]nomachine[dot]com putting the title of your topic as the email subject.

    Thanks!

    #34176
    lottolearn
    Participant

    Hey, so sorry I will do this now

    The topic wasn’t approved and I had forgotten about it have been trying to search around and fix this. It has to do with mac permissions I bet, as I see the disk pop up then immediately go away on file explorer

     

    It is weird, it hangs my mac if I try to do any commands on terminal until the mounting fails

    #34186
    fisherman
    Moderator

    We think that possibly nxfs.kext is not loaded. Please can you check following article: How to allow audio, device sharing and USB forwarding on macOS (‘System Extension Blocked’ since macOS 10.13).

    #34191
    lottolearn
    Participant

    Hi,

    Audio has been working for me always, but I did notice that that option was showing about it being blocked so I set to allow, and restarted but it hasn’t fixed it unfortunately.

    #34277
    lottolearn
    Participant

    Hey, any more information for me to use for troubleshooting?

    #34285
    tsotne
    Participant

    Hi,

    to help and to be more clear, can you tell me:

    1. What are you doing exactly? When you connect from the Windows client to the Mac server, do you forward Mac’s disk on Win or Win’s disk on Mac?

    2. Does it succeed or not? If not, what do you get as an error?

    3. What are the client and server NoMachine versions?

    4. What are the Mac and Windows versions?

    5. When does the Mac hanging starts? While trying to forward disk or after also when if it succeeded?

    6. What is the output of the command below on Mac?
    kextstat|grep nx

    #34396
    lottolearn
    Participant

    Hi,

    1. What are you doing exactly? When you connect from the Windows client to the Mac server, do you forward Mac’s disk on Win or Win’s disk on Mac?
    Connecting from Windows machine to MacOS. I am forwarding a disk from Windows to the Mac. I have multiple disks and none of them work.

    2. Does it succeed or not? If not, what do you get as an error?
    It fails, and the error is above is the one that pops up.
    There are no other errors, I even tailed nxerror and watched while it failed with no error msg in log

    3. What are the client and server NoMachine versions?
    7.6.2 Client
    7.6.2 Server

    4. What are the Mac and Windows versions?
    Windows 10.0.19042 Build 19042
    MacOS Big Sur

    5. When does the Mac hanging starts? While trying to forward disk or after also when if it succeeded?
    As above, it doesn’t succeed. It hangs once I click connect from NoMachine menu, and I see the disk briefly mount in the directory from finder, and it disappears. If I’m running a tail or even an ls command on terminal it hangs until it’s done.

    6. What is the output of the command below on Mac? kextstat|grep nx
    Executing: /usr/bin/kmutil showloaded

    No variant specified, falling back to release

    156    0 0xffffff7f9ce98000 0x3000     0x3000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <148 6 5 3 1>

    #34411
    tsotne
    Participant

    Hi,
    when you mention that Mac starts hanging, do you mean NX session (do you use terminal in session or are you checking it on actual machine) or actual system starts hanging?

    When you press connect button, does it show up permission asking widget for nxfs? or does it show that it is blocked?
    https://knowledgebase.nomachine.com/AR01P00962 even if you already allowed it? Can you check does it actually blocked?

    Also, can you run again this command while you are forwarding disk and when it fails after too:
    kextstat|grep nx

    After forwarding fails, can you click again on disk (it will show red exclamation mark on it) and check does it show some error message above “export this disk at session startup” option?

    #34439
    lottolearn
    Participant

    Thanks again for helping, for your questions:

    when you mention that Mac starts hanging, do you mean NX session (do you use terminal in session or are you checking it on actual machine) or actual system starts hanging?

    The actual macOS terminal hangs, so it is the mac system hanging itself (only the terminal hangs, not the macOS itself e.g. chrome if it was opened. If that makes sense, basically any command that is ran in Terminal (e.g. if I ran a “ls”) it will hang until the mount fails, then ls will display the results.

    When you press connect button, does it show up permission asking widget for nxfs? or does it show that it is blocked? https://knowledgebase.nomachine.com/AR01P00962 even if you already allowed it? Can you check does it actually blocked?

    No permission pops ups for nxfs. I’ve allowed. File sharing is and I have “Everyone” allowed to read write. I also set NX to read write, but that should be covered under everyone.

    nxclient, nxserver, nxnode, and NoMachine entries are all added for Full Disk Access in Security and Privacy

    Same for Accessibility, and Screen Recording options.

    I have completed that article already before.

    Also, can you run again this command while you are forwarding disk and when it fails after too:

    Before Running
    Executing: /usr/bin/kmutil showloaded
    No variant specified, falling back to release
    164    0 0xffffff7f9ce98000 0x3000     0x3000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <128 6 5 3 1>

    During running mount (fails)
    Executing: /usr/bin/kmutil showloaded
    No variant specified, falling back to release
    164    0 0xffffff7f9ce98000 0x3000     0x3000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <128 6 5 3 1>
    189    0 0xffffff7f9ccba000 0x3000     0x3000     com.nomachine.driver.nxusbproxy (130.10) 2042D4C4-F2A8-3F60-A690-3F0E5FEFA06B <8 6 5 3 1>
    190    0 0xffffff7f9ccd8000 0x1000     0x1000     com.nomachine.driver.nxusbvic (130.10) 8410FE92-FC08-350D-8C55-BD983F6717A4 <14 8 6 5 3 1>
    191    0 0xffffff7f9ccb3000 0x6000     0x6000     com.nomachine.driver.nxtun (4.1.b4) 01F02277-4C8E-3D43-A2B7-A77738C8D210 <8 6 5 1>
    192    0 0xffffff7f9ccbf000 0x15000    0x15000    com.nomachine.driver.nxusbvusb (130.10) AD25CADC-FAE8-31E5-9F00-418D868B37FE <66 22 14 8 6 5 3 1>
    193    0 0xffffff7f9cca1000 0x10000    0x10000    com.nomachine.kext.nxfs (4.1.b1) BFEE045F-718B-31CD-AA31-0E114A139EB3 <8 6 5 3 1>

     

    Post run
    Executing: /usr/bin/kmutil showloaded
    No variant specified, falling back to release
    164    0 0xffffff7f9ce98000 0x3000     0x3000     com.nomachine.driver.nxau (4.1.b2) 78172556-B6A4-3112-BA41-E79D18108476 <128 6 5 3 1>
    189    0 0xffffff7f9ccba000 0x3000     0x3000     com.nomachine.driver.nxusbproxy (130.10) 2042D4C4-F2A8-3F60-A690-3F0E5FEFA06B <8 6 5 3 1>
    190    0 0xffffff7f9ccd8000 0x1000     0x1000     com.nomachine.driver.nxusbvic (130.10) 8410FE92-FC08-350D-8C55-BD983F6717A4 <14 8 6 5 3 1>
    191    0 0xffffff7f9ccb3000 0x6000     0x6000     com.nomachine.driver.nxtun (4.1.b4) 01F02277-4C8E-3D43-A2B7-A77738C8D210 <8 6 5 1>
    192    0 0xffffff7f9ccbf000 0x15000    0x15000    com.nomachine.driver.nxusbvusb (130.10) AD25CADC-FAE8-31E5-9F00-418D868B37FE <66 22 14 8 6 5 3 1>
    193    0 0xffffff7f9cca1000 0x10000    0x10000    com.nomachine.kext.nxfs (4.1.b1) BFEE045F-718B-31CD-AA31-0E114A139EB3 <8 6 5 3 1>

    After forwarding fails, can you click again on disk (it will show red exclamation mark on it) and check does it show some error message above “export this disk at session startup” option?

    The error is just a generic

    “Failed to connect the disk H:/”

    I tried exporting as public, and private as well as changing the export as — no luck

    I changed the public export to the public folder on macOS, from the default mount folder but still no luck

    #34480
    tsotne
    Participant

    Hi again,

    I tried many times but was never able to reproduce that issue (with the same setup, same versions), can you check while you getting this behavior, if there are some crashes related to nxnode?

    https://support.apple.com/en-ge/guide/console/cnsl664be99a/mac

    If yes, please upload the corresponding crash report(s).

    #34487
    lottolearn
    Participant

    Hi,

    No crash logs but there are console messages when I try to mount it

    error 13:22:13.102790-0500 kernel System Policy: nxserver.bin(118) deny(1) system-privilege 10006

    com.apple.mDNSResponder default 13:22:13.134397-0500 mDNSResponder [R28837] DNSServiceQueryRecord(15000, 0, <mask.hash: ‘THdYPejrX5jVEYFfnVS/Xg==’>, Addr) START PID[118](nxserver.bin)

    com.apple.mDNSResponder default 13:22:13.134816-0500 mDNSResponder [R28837] DNSServiceQueryRecord(15000, 0, <mask.hash: ‘gVpRIfcaJURddPqDgVnHSw==’>, Addr) STOP PID[118](nxserver.bin)

    com.apple.networkextension default 13:27:06.125504-0500 neagent Failed to find nxserver in LaunchServices

    com.apple.networkextension default 13:27:06.125667-0500 nehelper Failed to find nxserver using neagent

    I’m not able to really find more info on it.. but maybe I suspect it is something to do with my network

    I tried disabling my firewall, and no luck.. Not on any sort of VPN on my home network

    I also recently switched ISPs, and it’s still doing it for both.

    #34493
    tsotne
    Participant

    Hi,

    these messages seem ok for disk forwarding, network agent extension shouldn’t do anything with disks.

    From previously reply, I see that when you try to forward disk nxfs loading, but to be sure we don’t miss something, can you do the following:

    – open the console app on Mac.
    – enable/start log messages.
    – connect again from Windows and try to forward disk.
    – when you reproduce the same behavior, you can stop logging in console app.
    – filler log messages with nxfs.
    – check if there is some unusual message or error/warning for it.
    – if it’s possible, copy all of them and I’ll check too.

    #34688
    lottolearn
    Participant

    Hey,

    Thought I had replied to this but turns out I didn’t sorry

    Found the issue

    nxfs: caller is not a member of nxfs admin group. Either add user (id=501) to group (id=0), or set correct ‘vfs.generic.nxfs.tunables.admin_group’ sysctl value.

    Seems like an open bug

    Sudden termination of the nxfs service on macOS Catalina

     

     

    #34700
    tsotne
    Participant

    Hi,
    what is explained in the TR is different in your case, why do you think it’s the same? Do you do any operation (described in TR) too?

    I also checked again replicating your set up and it is working for me. I see same warning in logs as well, wheel group and usually only root user is part of it. But this is not a problem, forwarding should work.

Viewing 15 posts - 1 through 15 (of 20 total)

This topic was marked as solved, you can't post.