NoMachine caused intermittent network issue?

Forums / NoMachine for Linux / NoMachine caused intermittent network issue?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17171
    Avatarotlichnik73
    Participant

    Hi there everybody! Here is a question from a tech dummy….please bear with me …

    Have been using free version NoMachine for a few weeks, love it. Use it to connect to two other PCs on same LAN.

    Mostly connect from Linux Mint Pc to Windows10. Works great – but, since first installing NoMachine noticed an issue – seem to lose internet connection for a while after disconnecting from NoMachine server; and sometimes it happens randomly, even when I did not use NoMachine on that day. Also sometimes lose internet connection on either client or host while connected via NoMachine.

    PC still shows that it is connected to network; but browser page won’t load and email client won’t send/receive. After a while, goes back to normal.

    Maybe it is a coincidence, but it started happening since NoMachine came on the scene.

    Any ideas, anyone? Please remember – you are dealing with a bit of a tech dummy…

    #17176
    Avatarfra81
    Moderator

    Hi!

    You may try to disable mDNS broadcasting and discovery in NoMachine.

    To disable broadcasting from servers, click on the NoMachine tray icon and unselect Show the service status -> Server preferences -> Services -> Advertise this computer on the network.

    To disable discovery on clients, select Player preferences -> Privacy -> Don’t show other computers on the network.

    You can change one of those two options at a time. The important thing is that you apply them an all machines of your network.

    #17257
    Avatartitan
    Participant

    @Fra81, just for the record, it sounds a bit unlikely that a small amount of multicast UDP packets can cause such an issue, although I agree that it’s best to test. Anyway (again for the record), did we have any report of other issues, directly or indirectly related to mDNS?

    #17316
    Avatarotlichnik73
    Participant

    Disabled discovery, but this did not help. No other issues encountered.

    once again, this is what happens – after disconnecting from NM server (stopping the connection), internet browser on the client takes a long time to connect. Email client on client machine, when attempting send-receive, times-out, giving message “error in name resolution”. But after about 2 minutes it goes back to normal…

    #17348
    AvatarGiorgi-G.
    Contributor

    What type of Ethernet card you use on this PC? Maybe it’s USB Ethernet adapter?

    #17419
    AvatarBritgirl
    Keymaster

    @otlichnik73 to check where the problem is on your network, you could use a third party tool such as Wireshark. This will help you troubleshoot your network problems by capturing, filtering and inspecting packets. Check out this article here https://www.lifewire.com/wireshark-tutorial-4143298 if you want to know more about how to use it.

    By zipping up the files and sending them on to forum[at]nomachine[dot]com, we’ll also be happy to take a look.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.