NoMachine causing Windows 11 22H2 to freeze when using webcam with USB passthrough?

Forums / NoMachine for Windows / NoMachine causing Windows 11 22H2 to freeze when using webcam with USB passthrough?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #42616
    DavidB
    Participant

    I have some concerns that NoMachine may be the source of issues that I am having on my computer after updating to Windows 11 22H2. I seem to observe a regularly occurring pattern of my computer randomly freezing. Everything stops responding, and the “solution” is to crash my computer and restart it. I don’t know for sure that NoMachine is at fault, but the reason that I suspect that it may be is because I have only observed it happening whenever I am connected to a NoMachine session and passing my webcam through to the remote computer using the USB passthrough feature.

    #42661
    Britgirl
    Participant

    Is the webcam integrated into your computer (so laptop for example) or is one that you can attach yourself? If it’s the latter, what make is it?

    #42663
    DavidB
    Participant

    The webcam is external and attached through USB. It is a Logitech QuickCam Communicate Deluxe.

    I still believe the issue is related to NoMachine, however, I have now encountered the freezing issue even when I don’t use the USB passthrough for the webcam. It only happens when remoting in to this one specific machine. When I use NoMachine to access any other machines, it does not happen. Or at least, I have not seen it happen so far. The only thing I can think of that is different about this machine compared to others is that it has multiple monitors attached to it, and I have the display stretched across multiple monitors as well to accommodate it.

    #42692
    Giorgi-G.
    Contributor

    Hi,

    There is a way to check for sure if NoMachine is a reason for this issue or not. For that, you need to unregister the “NoMachine USB Hub Filter”.

    Steps to do:

    1. Open Windows registry:  Menu Start -> run -> regedit

    2. Find the following registry key in the tree on the left:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\36fc9e60-c465-11cf-8056-444553540000

    3. Find the UPPERFILTERS variable on the right side. Edit UPPERFILTERS variable and remove “nxusbf”.

    4. Reboot the Windows machine.

    5. Check UPPERFILTERS, to make sure that “nxusbf” is not registered. USB devises forwarding won’t work anymore.

    6. Wait to check if the freezing occurs.

    #42718
    DavidB
    Participant

    The problem with doing this is, I need the USB Passthrough.

    #42769
    Giorgi-G.
    Contributor

    Did I get it right that your client machine (the one with Win 22H2) is freezing only when you connect to one specific remote machine with a multiple-display setup?

    Assuming that you don’t use USB passthrough on that machine, you can try to use a different display setting and see if that works.

    The test I described above could be performed for some short period (i.e., a day) to ensure that it’s not because of USB passthrough. After the test is done, you can enable USB forwarding back.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.