NoMachine changing the resolution on my Mac host

Forums / NoMachine for Mac / NoMachine changing the resolution on my Mac host

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #33537
    keyosuke
    Participant

    I’m on a Windows based client connecting to an Apple Macbook host and the Macbook’s resolution starts out much higher than the physical monitor that is built into this Macbook, but the graphics hardware supports this high resolution and scales it down for the monitor, but when NoMachine detects a client connection the Mac host immediately changes resolution down to the very small physical monitor of the laptop.  As soon as NoMachine client on Windows disconnects from NoMachine server on Mac, the massive resolution I use on the mac is restored.

    I do not have this issue with other remote control software like VNC or even RDP, but I would prefer to use NoMachine, because it is so much more responsive; I think it’s better software.  I just hate having to use a very small screen resolution on my Macbook while remote viewing it if the Macbook itself is running at a higher resolution until NoMachine forces it to switch.

    #33541
    fisherman
    Moderator

    I am thinking that you are have selected “Resize remote screen” (see screenshot). For remote resolution to stay the same please use “Enable viewport mode” or “Scale to window”. Please find more information in the article Some tips about resize and scaling options for NoMachine client version 4 or later.

    #33550
    keyosuke
    Participant

    I thought I had tried every combination of those settings and it hadn’t fixed it, so I tried what you said and my problem is solved.  If you’re ever in New Jersey I’ll happily buy you a beer or coffee.   Thank you.

    #33570
    fisherman
    Moderator

    Thanks for letting us know. I might not get to New Jersey in the near future, but I can happily accept a virtual beer or coffee 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.