NoMachine client blocks VirtualBox USB

Forums / NoMachine for Windows / NoMachine client blocks VirtualBox USB

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16171
    bkleven
    Participant

    Hi,

    I’m using NoMachine Enterprise Client for Windows 5.3.12_5.  I noticed that I could not get host USB devices to work in my CentOS VM running in VirtualBox.

    After much debugging, I realized it was NoMachine that was causing the issue.  I found the post (it’s two years old) on these forums stating that I need to run ‘nxservice64 -uninstall nxusb’ and then reboot.  Unfortunately, this doesn’t work.  I ran the command from an Administrator privelaged cmd.exe command prompt.  The additional commands to run ‘nxservice64 -status nxusb’ didn’t work either – there were no results.

    Looking in device manager, it continued to show that nxusbf.sys was bound to every new USB device.  The only option was to uninstall the NoMachine client – I even tried disabling the NoMachine Device Server (nxservice64) using the Services mmc plugin.  No difference, even afer reboot.

    What options are there to have VirtualBox and NoMachine coexist peacefully?

    #16203
    Giorgi-G.
    Contributor

    Hello,

    In that case you can disable NoMachine USB driver on Windows.
    It will allow you to keep using NoMachine as long as the USB driver is disabled.

    To do that, just follow next steps:

    1) First step is to remove all devices:
    a) Run the device manager: Control panel -> Device Manager
    b) Uninstall all “NoMachine USB Stub” devices if they exist.
    c) Uninstall all “NoMachine USB Host Adapter” devices if they exist.

    2) Second step is to remove all drivers:
    a) Run console with administrator rights:
    Menu start -> Run -> cmd -> Right click -> Run as administrator
    b) Run the Windows sc.exe tool from console:
    > sc stop nxusbf
    > sc stop nxusbh
    > sc stop nxusbs
    > sc stop nxusbd

    > sc delete nxusbf
    > sc delete nxusbh
    > sc delete nxusbs
    > sc delete nxusbd

    Note: when given service doesn’t exist yet, sc tool returns error 1060, which is not an error in this case.

    3) Third step is to unregister “NoMachine USB Hub Filter”
    a) Open Windows registry:  Menu start -> Run -> regedit
    b) Find the following registry key in the tree on the left:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\36fc9e60-c465-11cf-8056-444553540000
    c) Find UPPERFILTERS variable on the right side.
    Note: it should contain list of registered filters, but maybe it’s empty if no filter is registered.
    Edit UPPERFILTERS variable and remove entries containing nx prefix (e.g. “nxusbf”) if they exist.
    d) Reboot the machine.

    Best Regards.

    #16208
    bkleven
    Participant

    Hi Giorgi,

    Thanks for the detailed steps.  This general process was my next idea to try but I wasn’t sure how to do it at that level of detail, so thanks for the information!

    Kleven

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.