NoMachine connection fails first attempt, second attempt always successful

Forums / NoMachine for Windows / NoMachine connection fails first attempt, second attempt always successful

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30307
    Avatararliinsandbulte
    Participant

    I think the issue is related to the remote machine’s Power & Sleep setting.

    The remote PC Screen is set to turn off after 3 hours.
    If it has been 3 hours and the screen is off when I connect, NoMachine displays the desktop, but mouse and keyboard input do not respond.
    After closing NoMachine and reconnecting, mouse and keyboard inputs work as expected.

    Remote & local OS: Windows 10
    NoMachine Version: 6.12.3 free version
    Connecting to a physical display on remote machine (3 displays are connected)

    #30446
    AvatarBritgirl
    Keymaster

    We haven’t been able to reproduce this at all. Please send us a screenshot from the Advanced Power Settings plus logs from the affected Windows server host. Please see here for instructions on where to find logs.

    https://www.nomachine.com/AR10K00697

    Submit everything to forum[at]nomachine[dot]com making sure to use the title of this topic as the subject of your email. Thanks!

    #30450
    Avatararliinsandbulte
    Participant

    I have submitted the log files as requested.
    And, I made a video of all the Advanced Power Settings and sent that in an email too.

    Here is some more info on this behavior:

    1. When connecting the first time, I *DO* have mouse and keyboard control of the remote (server) PC, but I cannot see it.  I only see a static image of the remote desktop.  When double click on a desktop icon, nothing happens locally.  But, when I quit NoMachine and connect the second time, the program that I double clicked on is open and running.
    2. On the local machine, when I connect the first time, I see the remote (server) PC desktop, but when I move the mouse, the remote (server) mouse seems to just drift and not follow my local mouse cursor.  (I have show server mouse icon enabled).
    3. The remote (server) PC has 3 screens attached.
    4. The remote (server) PC is configured to login to a standard user (non-admin) account automatically at boot.  This is set by running the netplwiz utility:
      Then, in the User Accounts dialog box, click the account you want to automatically log on to.
      Then, clear the ‘Users Must Enter A User Name And Password To Use This Computer’ check box.
      Then, Click OK

    Hope that helps.  Thanks!

    #30451
    Avatararliinsandbulte
    Participant

    Another user that remotes into the same PC is on Mac and also sees the same issue when first connecting.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.