NoMachine disables sound permanently on server (Ubuntu 22.04)

Forums / NoMachine for Linux / NoMachine disables sound permanently on server (Ubuntu 22.04)

Tagged: , ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #39722
    XQC
    Participant

    When connecting remotely to my Ubuntu 22.04 laptop I noticed that once NoMachine establishes a connection the hardware sound on the laptop is gone. The remote sound is working, but no hardware sound anymore.

    All volume sliders indicate that there should be sound and in the sound settings everything is set as it should be. Even when playing sound, the sound meters show that there should be sound.

    Disabling and enabling the sound in NoMachine does nothing as well as shutdown the NoMachine Server. Even uninstalling NoMachine on the server did no good.

    Also all terminal tools regarding Alsa and Pulseaudio won’t return the hardware audio.

    Only solution – so far – was to go back to a system snapshot created with Timeshift.

    Then I looked into what NoMachine changes once a remote connection is established.

    I found that NoMachine edits all values /var/lib/alsa/asound.state to zero – but in such a way, that there is no way to get the sound back via GUI or the standard terminal apps and mixers.

    NoMachine doesn’t restore the values in asound.state once the remote session ends.

    As I said, there is also no audio setting, that brings back the audio, I tried everything.

    So I consider this behavior a bug.

     

    #39775
    Britgirl
    Keymaster

    Hi, we can’t reproduce this on Ubuntu 22.04.
    However, we found this which would would suggest it’s an Ubuntu bug.

    How to resolve no sound problem on Ubuntu 22.04
    https://zcom.tech/ubuntu-no-sound.html

    Maybe this is your case?

    #39843
    fishnet37222
    Participant

    I can reproduce this issue on Linux Mint 21.

    I tried to follow the steps in the article you linked to, but one of them was to uninstall pulseaudio, which would have uninstalled Cinnamon itself, and I wasn’t about to do that.

    #39927
    Britgirl
    Keymaster

    We’ve not been able to reproduce this problem, despite several attempts. Are you able to send us the logs from the server sideso we can take a look? Please follow the instructions here and send them forum[at]nomachine[dot]com making sure to use the title of your topic as the subject of your email.

    How to gather debug logs for support requests
    https://kb.nomachine.com/AR07K00677

    #39928
    fishnet37222
    Participant

    I just tried to reproduce it again and was unable to.  Some piece of software in Linux Mint may have been updated since my last post on this thread, and that may have resolved the issue.

    I had switched back to Windows 11 on the laptop in question and reinstalled Linux Mint to attempt to reproduce the issue.

    #39930
    fishnet37222
    Participant

    After I made my previous post, I rebooted my laptop and the issue occurred again.  I’ve attached the server logs as requested.  I did install a few software packages after I made my previous post, but they had nothing to do with sound.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.