NoMachine for Linux ARM?

Forums / NoMachine for Linux / NoMachine for Linux ARM?

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6295
    Gibbio
    Participant

    Hello,

    I would like to know if there is a Linux ARM version (ARMHF + NEON) of NoMachine Client 4.x. I ask that why, I would like to use it in the new Raspberry Pi 2 Board 🙂

     

    Thanks,

    Gibbio (rpitc.blogspot.com)

    #6338
    Britgirl
    Keymaster

    yes, there is 🙂 It has been a popular request. We will be releasing one in Alpha for users to try – possibly next week. We’ll let you know here when the packages are available. We’ll also post to the RPi forums to let all Raspberry users know as well.

    #6344
    Gibbio
    Participant

    Woooahhh! Great! Thanks!

    #6352
    reza
    Moderator

    Please take a look at corresponding feature request https://www.nomachine.com/FR02M02867.

    Initial version will be compiled for ARMv7 armhf so you will need one of these images to play with it:

    http://www.raspberrypi.org/forums/viewtopic.php?t=98997

    http://sjoerd.luon.net/posts/2015/02/debian-jessie-on-rpi2/

    ARMv6 armhf compilation for Raspbian is next in queue.

     

    #6423
    Britgirl
    Keymaster

    Good news!!! We have a client build available for Linux ARMv7, and the ARMv6 armhf compilation for Raspbian is now complete. Users who are interested in trying them out, please contact us (Contact Us link in the footer) to get further details 🙂

    #7100
    Britgirl
    Keymaster

    Update: Users can now freely download the alpha packages for Raspberry Pi and other ARM devices from the website.

    #7830
    jay
    Participant

    Hi, I love to use NoMachine on RaspberryPi-2 that I use for digital signage.

    I’ve installed: nomachine_4.6.4_1_armhf.deb 

    by running the command: <span style=”color: #404040; font-family: Gudea, ‘AG Foreigner Light-Plain Medium’, sans-serif, sans-serif; line-height: 14.3999996185303px; background-color: #ffffff;”>$ sudo rpm -i nomachine_4.6.4_1_armv6hl.rpm</span>

    But I’m seeing repeated dependancies which are stumping me;

    <p class=”p1″><span class=”s1″>~/Downloads $</span><span class=”s2″> sudo dpkg -i nomachine_4.6.4_1_armhf.deb </span></p>
    <p class=”p1″><span class=”s2″>(Reading database … 78093 files and directories currently installed.)</span></p>
    <p class=”p1″><span class=”s2″>Preparing to replace nomachine 4.6.4-1 (using nomachine_4.6.4_1_armhf.deb) …</span></p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxdiag.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxdifb.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.17′ not found (required by /usr/NX/lib/libnxdifb.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxdift.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxdixl.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnx.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxc.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxcau.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxcau.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxcde.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libnxne.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.17′ not found (required by /usr/NX/lib/libstdc++.so.6)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libvp8.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libvorbis.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libspeex.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libspeexdsp.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libm.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libasound.so)</span></em></p>
    <p class=”p1″><em><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.16′ not found (required by /usr/NX/lib/libasound.so)</span>
    </p>
    <p class=”p1″><span class=”s2″>/usr/NX/bin/nxserver.bin: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15′ not found (required by /usr/NX/lib/libmdnsd.so)</span></p>
    <p class=”p1″><span class=”s2″>dpkg: error processing nomachine_4.6.4_1_armhf.deb (–install):</span></p>
    <p class=”p1″><span class=”s2″> subprocess new pre-installation script returned error exit status 1</span></p>
    <p class=”p1″><span class=”s2″>Errors were encountered while processing:</span></p>
     nomachine_4.6.4_1_armhf.deb  

    As an additional note, I read this in the NoMachine notes:

    <span style=”color: #404040; font-family: Gudea, ‘AG Foreigner Light-Plain Medium’, sans-serif, sans-serif; font-size: 14px; line-height: normal; background-color: #ffffff;”>As a further note for Linux users, the client.zip archive ships an nxclient executable that links dynamically with GLIBC and requires libstdc++ version 6 to be present on the system. Since it provides support for font antialising, it also requires the XFT libraries (libfontconfig.so.1 and libXft.so.2) be present on the system. These requirements are present on all the most recent Linux distributions.</span>

    Does anyone know the fix for this?

    #7855
    reza
    Moderator

    Are you using Raspbian on your RPI2 device?

    If yes then please download a version for ARMv6 available on our page.

    A version you used is for Ubuntu/Debian build for ARMv7.

    #8052
    Britgirl
    Keymaster
Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.