NoMachine forgets UPnP settings between reboots

Forums / NoMachine for Mac / NoMachine forgets UPnP settings between reboots

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #40339
    HippoMan
    Participant

    I’m using NoMachine 8.0.168 under MacOS 11.7 (“BigSur”). When I connect to my Mac via NoMachine, I ususally do so from my Linux machine (Ubuntu 20.0.4 running XFCE4) running NoMachine 7.9.2.

    The problem I’m reporting is solely related to my Mac.

    I need to use UPnP in my network enviroment from the Mac, and when I set UPnP in NoMachine on the Mac, it works fine. I have NoMachine set up to automatically start on the Mac’s system login, and it always indeed starts properly when the Mac system starts.

    However, the UPnP settings for NoMachine always get forgotten after a reboot of my Mac. After every restart, I have to manually go into NoMachine on the Mac and re-enable these UPnP settings before I can remotely connect to my Mac via NoMachine.

    Is there any way to get NoMachine to remember these UPnP settings between reboots on my Mac?

    Thank you very much in advance for any help and suggestions/

    #40363
    Britgirl
    Keymaster

    When you are speaking about UPnP you are speaking about the mapping of the port to the router via UPnP (just to clarify for other users who might be reading šŸ™‚ )

    When the nxserver starts up and it makes the request to the router according to how you’ve set up port-mapping, it can some time before the router responds. In our tests, there were some specific models that can take up to 9 minutes before responding back to the server. In the current version, during this time, the player asks the server to confirm the upnpstatus but the nxserver is still waiting for the router to answer. You will probably see that if you leave the Ports panel open, it will update itself after a few minutes (because the nxserver has received a response from the router).

    In the next update we will change this behaviour between server and player. The server will tell the player that the setting is activated (or not) even though it is still waiting for the router to respond. This should remove the need to have to manually change it every time.

    #40383
    HippoMan
    Participant

    Thank you very much for explaining, and for letting me know that this will be fixed soon!

    I’m looking forward to this being corrected, because this way, if my Mac reboots, I can be far away from that computer and still start using NoMachine to connect to it. As it is, I have to manually enable NoMachine’s ability to listen for connections every time the Mac restarts, and this prohibits me from connecting remotely until I perform that manual step.

     

    #40386
    Britgirl
    Keymaster

    Iā€™m looking forward to this being corrected

    Although we will be releasing a maintenance shortly (keep your eyes peeled for that) the change we mentioned will be in one of the next upcoming updates.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.