NoMachine "forgets/ignores" local groups assigned via /etc/security/group.conf

Forums / NoMachine Cloud Server Products / NoMachine "forgets/ignores" local groups assigned via /etc/security/group.conf

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4499
    henrik
    Participant

    Hi,

    We have installed the enterprise version on a Linux computer (Ubuntu server 14.04 with KDE desktop). We use an LDAP server for user authentication. As soon as user log into the server they are added to  local groups ( in our case “fuse” and vgluser) using “*;*;*;Al0000-2400;fuse,vglusers” in “/etc/security/group.conf“. This works perfectly for ssh logins and also for local logins, but not for users logging into the system by spawning a NoMachine virtual desktop (happens for both KDE or console only). The local groups are ignored. If I want to make sure that LDAP users are assigned to local groups in the NoMachine session,  I must explicitly add them to  “/etc/group” which is a rather bad solution.

    Did anyone experienced a similar problem? Any ideas?

    Any help is highly appreciated.

    Best,

    Henrik
    Server:   NoMachine Enterprise Server Subscription – Version 4.2.27 on Ubuntu 14.04

    Client: Ubuntu 14.04, Windows 7. Both with most recent Free version of NoMachine client

    Problem occurs with both “KDE desktop” and “console only” virtual display

    #4534
    Cato
    Contributor

    Hello henrik,

    Unfortunately, assigning LDAP users to local groups, using pam_group module is currently not supported.
    We created TR:  https://www.nomachine.com/TR08L04515 and are going to deal with this issue.

    Thanks for reporting.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.