NoMachine freezes after password entry

Forums / NoMachine for Linux / NoMachine freezes after password entry

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29530
    Avatarv8owner
    Participant

    I have searched the forums and knowledgebase but cannot find any solutions for this particular issue.

    I’m running Linux Mint 20 (Cinnamon, fully updated) on three computers. One of these acts as a file server. It is in a difficult-to-access location, and on occasion I need to use remote control. In the past I tried several different remote desktop applications but found NoMachine to just simply work, so it’s been my remote control application of choice. Until recently, that is.

    (NoMachine version 6.11.2 on both server and client)
    The issue: I start up the NoMachine client and connect to the server. I see the login screen, select the username, and type in the password. Everything’s fine up to this point. However, the minute I press “enter”, the remote screen freezes. No matter how long I leave it, there is no change. I can close the NoMachine session, and the server is still running fine. I just can’t access it! The only way I can regain access is by issuing a reboot command via Webmin. I can then log in using NoMachine without any issues. Just once. If I  log out again, NoMachine is again in the “freeze” condition if I ever try to use it again. The only solution is to reboot the server. Again. Anyone else experiencing this?

    #29670
    AvatarBritgirl
    Keymaster

    We tried to reproduce this and did, but even without a NoMachine session. I.e. the problem is reproducible on the actual physical host.

    A related topic is under discussion on the Linux Mint forums:

    https://forums.linuxmint.com/viewtopic.php?t=323505

    #29675
    Avatarfra81
    Moderator

    Just to be sure that it is not related to a Cinnamon issue, can you tell us if restarting the NoMachine server only (without rebooting the machine) is enough to fix the problem? Also logs could be useful to understand better what is happening (https://www.nomachine.com/DT10O00163#1). You can send them to forum[at]nomachine[dot]com.

    #29681
    Avatarv8owner
    Participant

    Britgirl – that link is irrelevant I’m afraid. I was not using suspend, nor is any screensaver enabled.

    fra81 – I had tried restarting the server without rebooting. The problem persisted. Logs were sent on the 23rd September.

    However, I am now no longer using NoMachine so this topic can be closed.

    #29686
    AvatarBritgirl
    Keymaster

    Just to confirm. We received no logs from any domain concerning this particular topic. The case can be closed now.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.