NoMachine interferes w/ screensaver/power management?

Forums / NoMachine for Linux / NoMachine interferes w/ screensaver/power management?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #10231
    Avatarcolin
    Participant

    When I run the NoMachine 5.0.63-1 (free version) service on my Linux Mint 17.3 Xfce desktop, it seems to prevent the power manager and screensaver from blanking the screen, even with no remote user connected. I can still lock the screen manually from the session menu. If I turn connections off under NoMachine’s “connection status”, the power manager and screensaver are able to blank the screen.

    Has anyone else encountered this? Is there a workaround? I saw “Under certain conditions a Linux PC fails to suspend“, but that’s been fixed.

    I accidentally scrambled my session config while trying another remote solution before I installed NoMachine, so the problem might be a strange quirks on my system, but the problem only happens when NoMachine is running.

    #10254
    Avatarkroy
    Contributor

    NoMachine without connected sessions shouldn’t have any influence on the screensaver and power options. We couldn’t reproduce that problem in our lab. Are you sure there is no application that triggers any screensaver to start and the problem doesn’t exist when nxserver is disabled? Are you using xscreensaver as default screensaver on that machine? Can you write exactly what session configuration you have changed?

    #10403
    Avatarcolin
    Participant

    I’ve run into some other little problems, so I think I’m going to just reinstall my system to eliminate config quirks (I’d hoped to wait until the next Mint release, but oh well). If any problems remain, I’ll ask about them then. I’m answering your questions below anyway for completeness.

    What happened to my config is that, while trying X forwarding (before I tried NoMachine), I tried to forward a whole desktop session (because I’d read in multiple places that this was possible). When I tried it I got a long list of errors, and eventually a default Xfce desktop (with none of the Mint modifications). I don’t know if the problem is just that I used the wrong Xfce command (there are 2 that start sessions) or if I shouldn’t have done it while a desktop session was already running, but after that my desktop had a lot of changed settings (e.g. different window manager buttons). I suppose some default Xfce settings got mixed in with the normal Mint ones. I fixed what I could but I imagine there are still less-noticeable changes and corruptions.

    I did indeed check that the problem doesn’t exist when nxserver is disabled, as mentioned in the original post. Since then I’ve found that nxserver does not interfere with the screensaver until the first time I use NoMachine to view the desktop. After that the problem remains until I log out of the desktop locally (I say “nxerver intereferes” because that is what seems to be happening; I understand it might not be the cause, I just need a way to talk about it). I’m using Xfce’s power manager to turn off the screen, but I tried it with xscreensaver before the original post and had the same problem (but I think I had both on at once, so that doesn’t tell us much).

    Updating to the recent new version of NoMachine didn’t solve the problem.

    Again, I’m going to reinstall my system so I can eliminate corruption as a possible source of problems; I just answered the questions in case anyone is curious. I appreciate your time.

    #10406
    AvatarBritgirl
    Keymaster

    You said you updated to the latest version. Is that the version we just released today?

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.