NoMachine on Mac audio forwarding stutters

Forums / NoMachine for Mac / NoMachine on Mac audio forwarding stutters

Tagged: , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #21892
    naryfa
    Participant

    Hello,

    I connected from Win10 client to Macbook Air ‘server’. I have the audio routed to the Win10 computer (as it has better speakers), but the audio stutters at times. Both computers are physically connected via LAN cables to the router.

    I tried changing the graphics to MJPEG, then to H264, hoping it would offset the CPU load. I even blank out the physical screen, but it doesn’t seem to have any effect.

    I also disabled the microphone forwarding, as well as muted the host audio. Still hear occasional stutter.

    Is there anything else I could try without compromising the audio quality, or is audio streaming just so resource-intensive that it’s futile?

     

    #21903
    mkub
    Participant

    Hi,

    Stuttering can be caused either by low speed or high processor usage on the remote host (the Mac in your case).

    Do you have other programs open on the Mac whilst you have the session open? If you do, does closing them all other activity reduce the stuttering? Can you try with VP8 encoding?

    Thanks,
    mkub

    #21911
    naryfa
    Participant

    The only other program I have open is Top in terminal. Closing it has no effect. I did try the VP8 as well.

    Maybe this Mac just can’t handle the load. It is, albeit in good shape, an old machine. It’s a 2010 2.13Ghz Core 2 Duo with 4GB of RAM and 256MB nVidia 320M.

    I chose to test NoMachine on it because I wanted to buy a dedicated Mac Mini for a headless setup, but if I get stuttering like this on a decently configured Mac Mini, then that plan goes down the drain.

    Is it that the network traffic isn’t prioritized enough, and any CPU spike causes stuttering? Does it have anything to do with the “QoS”? Because audio on the Mac doesn’t skip, only once routed through the network.

    #21937
    mkub
    Participant

    It could be a hardware related case. To keep the best audio quality without stuttering you could try to decrease the quality of video stream in Display tab. Can you describe stutters? How often they appear and for how long it takes to restore proper stream?

    #22007
    naryfa
    Participant

    I decreased it to the lowest limit, no change. These are micro-stutters, like ticks in the sound, but they’re annoying. I think I will buy a decent Mac Mini and fire up NoMachine, then test it. Worst case scenario I’ll use it for something else. But I know for sure it’s not the network. The router, cables and computers are in the same room.

    I’ll report back when I have the setup in place.

    #22213
    naryfa
    Participant

    OK,

    I got a 2014 Mac Mini with 3GHz i7, 16GB of RAM and 512 Intel SSD. I’m not impressed by the performance, even though the machine is on the same LAN. The stutters are gone for the most part, but if there’s a heavy load the audio will momentarily skip while being passed through. Is there anything else I can adjust (without losing quality) to enhance the experience? I don’t want to believe that a gigabit LAN is a bottleneck…

    #22224
    mkub
    Participant

    Hi,

    We have reproduced the problem which you have described. You can find related TR under the link below.

    Audio stutters during NoMachine session
    https://www.nomachine.com/TR05Q09270

    #22316
    naryfa
    Participant

    Thank you for raising this ticket request. I will monitor it.

    In the mean time, I can connect regular speakers. Is it possible to stop NoMachine from injecting the audio sources into the guest OS? Setting the AudioInterface Disabled flag still lists the virtual device as shown on the attached picture.

    Attachments:
    #22343
    mkub
    Participant

    Hi,

    To resolve your problem close active sessions and call:

    kextunload /System/Library/Extensions//nxaudio.kext
    /etc/NX/nxserver --restart

    To load audio devices again to your system, call:

    kextutil /System/Library/Extensions//nxaudio.kext
    /etc/NX/nxserver --restart

    You need to be superuser to execute commands above.

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.