NoMachine on Plasma with Wayland

Forums / NoMachine for Linux / NoMachine on Plasma with Wayland

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #32749
    Avatarjjgalvez
    Participant

    Hi, I am switching from Gnome to KDE/Plasma on Arch Linux. Under Gnome NoMachine works without issue with Wayland. With Plasma, if the server is on the login screen (sddm) I can connect with NoMachine, however once I log in no sessions are available.  On the server when I log in and check nxserver –status I see that nxnode is disabled. If I use an x11 session rather than a Wayland session NoMachine connects without issue.

    Are there any workarounds to using KDE/Plasma with Wayland?

    Thanks

    #32779
    Avatarjjgalvez
    Participant

    Additional info I should have put in the initial post:

    Distro: Arch

    Plasma 5.21.3
    kwayland 5.8.0

    Wayland 1.19.0

    NoMachine 7.4.1

    #32786
    Avatarjjgalvez
    Participant

    One more update, to make sure I didn’t do something stupid when I installed Plasma on my Arch install I installed NoMachine on KDE Neon (in a VM) which is based on Ubuntu and when I try to connect to that server I get the same error that a display can not be found. Nxnode is also disabled.

    #32813
    Avatarjjgalvez
    Participant

    Including log files as suggested in another post. I hope someone can help, because at the moment Wayland Plasma sessions do not work.

    #32896
    AvatarBritgirl
    Keymaster

    We have reproduced it, you can track the bug report here: https://www.nomachine.com/TR04S10183

     

     

    #32914
    Avatarjjgalvez
    Participant

    Thank you

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.