NoMachine on Ubuntu shows only white screen

Forums / NoMachine for Linux / NoMachine on Ubuntu shows only white screen

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #18747
    Avatarmawe
    Participant

    Hi,

    I have trouble connecting from Ubuntu 16.04 to a server that is running on Ubuntu 18.04 (free version of NoMachine 6.2.4 on both machines). I have other servers to which I can connect with no problems.

    On the first try, I was still able to choose the server’s screen resolution but aborted due to other things I had to do here in the lab. When trying again to connect to the server, it asks for the password and seems to connect. The cursor gets black when hovering over the NoMachine window but the window stays white. I tried uninstalling NoMachine on the server, but the problem remains. My guess is, that NoMachine did not like me aborting during the first attempt to connect, but, unfortunately, I have no clue how to rescue it.

    #18754
    Avatargraywolf
    Moderator

    It looks the server desktop is running on Wayland. Is the server a virtual machine? In that case, you can revert to Xorg by uncommenting line #WaylandEnable=false in /etc/gdm/custom.conf and restarting the display manager with systemctl restart gdm.

    #18800
    Avatarmawe
    Participant

    Thank you very much!

    After a reboot, I can connect to the server. You were correct, though, the server is on a virtual machine, sorry, forgot to mention that.

    Best regards!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.