NoMachine port mismatch in router

Forums / NoMachine for Windows / NoMachine port mismatch in router

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #13823
    briansalzano
    Participant

    Hello Forum:

    May I get a little direction on this? I lost the connection between my home and office. Upon investigation, the problem turns out to be that my office router is redirecting to a different Gateway port than the NoMachine client welcome screen is instructing me to connect to. The router wants to redirect to 23868, but the NoMachine client welcome screen is telling me to connect to port 23844. Further, when I check the settings in the NoMachine client, the Gateway port is correct (23868).

    The connection does indeed work on 23868. So the router and service are both OK and the problem appears to be simply that the client welcome screen isn’t updating. I have done all the obvious stuff – restarted the service (no change), restarted the machine (no change).

    Screen clip “NoMachine…1.png” shows the mismatch between the welcome screen and the router. “NoMachine…2.png” shows the mismatch between the welcome screen and the settings view in the client software. For anyone without access to the images, the welcome screen is identifying the GW port as 23844 (wrong), the settings menu as 23868 (right).

    Thanks very much for any input.

    brian

    #13833
    kroy
    Contributor

    Thanks for the report. It’s a known issue and we are working on a fix. Meanwhile you can check port by using ./nxserver --upnpstatus command on console.

    #13847
    briansalzano
    Participant

    Kroy:

    Thanks. Vernacular check – by the console do you mean the command prompt? Or is there a NoMachine console I’m not aware of? This particular machine is a windows machine. The windows shell is telling me it doesn’t recognize that command.

    Otherwise, I presume that the settings value doesn’t have that problem and I can rely on it to be correct? Or is the problem common to both views?

    Thanks again – brian

    #13859
    kroy
    Contributor

    Yes, command prompt. Navigate to nxserver script – it’s in NoMachine\bin directory. In default on Windows 64-bit NoMachine is installing in Program Files (x86). So you can execute command: "c:\Program Files (x86)\NoMachine\bin\nxserver" --upnpstatus.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.