NoMachine requesting authentication from the desktop user to connect

Forums / NoMachine for Windows / NoMachine requesting authentication from the desktop user to connect

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9809
    AvatarDarknite999
    Participant

    Hi All,

    I am having trouble with NoMachine free.  I have AVC pack from NoMachine which I have a current licence for installed (just for informational purposes).

    The issue I am getting is when I try to connect I am greeted with a message, “Waiting for the desktop user to authenticate your connection”.

    This issue is replicated for me when I connect successfully once.  Disconnect and try to reconnect.  No amount of time waiting resolves this issue.

    If I ask another person to physically go to the machine I am trying to connect to and restart it I am then able to connect.

    This is highly annoying as I would like to connect and people are not always available to restart my machine for me so I can connect without authentication.

    I can confirm that the computer I am connecting to has the options, “Require permission to let remote users connect” and “Require permission to let remote users interact with the desktop” unticked.

    Can anyone please help me understand why my computer is ignoring these options.  It seems like it thinks I still have one of these options ticked when I do not.

    I have included pictures of when I am trying to connect and the settings of the place I am connecting to.

     

    Info on my systems:

    I am connecting from a Physical desktop at my place of work on Windows 10 enterprise 64-bit to my home PC (another physical machine) which is Windows 8.1 pro.  I only ever connect this way around.  I never connect to my work PC from home.

    Please let me know if you need anymore information

    Thanks,

    Jamie.

     

    #9837
    AvatarDarknite999
    Participant

    To add one more piece of information.

    When connecting to my home PC using NoMachine free, if I connect to my Home PC with another piece of remote desktop software at the same time so I can click Accept to the “Accept the incoming connection” message for NoMachine that pops up.  On my work PC I am greeted with a new message:

    Error is 138: Connection timed out.

    I can confirm that ports are forwarded correctly on my router (I use port forwarding all the time for other purposes). Windows firewall is also fully turned off and I don’t have a 3rd party firewall install.  Even though it shouldnt matter I turned off Avast avtivirus just in case this was causing the issue too.

    Thanks.

    #9851
    Avatarnars
    Contributor

    Hello Darknite999,

    We are not able to reproduce your issue in our labs so we will need more details.

    Did you restart NoMachine after unticking “Require permission to let remote users connect” and “Require permission to let remote users interact with the desktop” options? (by clicking on “Restart NoMachine for changes to take effect”).

    You can try to disable this option directly in server configuration file by setting a key “PhysicalDesktopAuthorization 0” in <NoMachine directory>/etc/server.cfg.

    Which NoMachine version are you using? We suggest to update to the latest 5.0.63 because restarting NoMachine after these options is no longer needed.

    Please note that attaching to the physical desktop requires permission only if you are logging with an account that is not the desktop owner i.e the user which is currently logged in to the system.

    Which other remote desktop software are you using to click “Accept the incoming connection”? We would like to check that it’s not interfering with NoMachine.

    If none of my hints help you then you will need to send logs and a content of server.cfg file. Please zip content of c:/ProgramData/NoMachine/var/log and c:/Program Files/NoMachine/etc and send them to forum[ at ]nomachine[dot]com.

     

     

    Regards.

    #9858
    AvatarDarknite999
    Participant

    Hello Nars,

    Thanks for the quick reply,

    These options were already unticked. I notice in my screenshot it does say “NoMachine requires a restart” but this was only because after getting this issue I tried ticking some options on this screen, then saving, then unticking them again. I did this just prior to writing on this forum (and grabbing a screenshot) so this is why the screenshot is saying this. Since yesterday (when I posted the issue), I had restarted both machines and not touched these options and the issues still persists.

    I will try the suggestion about editing the server file manually and let you know how this goes in my next reply. Do I add this line at the end of the server config file?

    I confirm that both client and host machine are up-to-date with the latest NoMachine verison of 5.0.63

    I have not updated the AVC pack since I updated the NoMachine version, would this be important?

    Please note that attaching to the physical desktop requires permission only if you are logging with an account that is not the desktop owner i.e the user which is currently logged in to the system.

    The physical desktop I am connecting to is NOT on a domain of any sort, it has just 1 local user account which is an admin. This user is password protected (so it can be used with NoMachine) and in the windows utility “userpasswords2” I have enabled the option of signing in this user automatically without the need for entering a password. This is the same user I use when connecting through NoMachine to my home PC as when I am physically at the desktop using this computer. The computer I am connecting to would also be logged into this user as I am trying to connect via NoMachine from work (since it is the only user on the machine). I hope this means everything is ok with how I have set this up.

    I use 2 other remote desktop software. Ammyy Admin and Teamviewer 11. Ammyy Admin is setup to allow “unattended access” which is what I use to accept the connection for NoMachine. I must admit, I have had this problem a while and been using Ammyy Admin to accept the NoMachine connection for a while which worked perfectly until I tried today. It appear this no longer works for me and as seen in my previous message I just get a Error is 138: Connection timed out after clicking the “Accept” button. Teamviewer 11 is not setup for unattended access of any sort and is only used for support purposes for my friends and family who require computer assistance.

    Thanks for the advice so far. If I could just get an answer to my question above (in bold) I can try all of your suggestions and come back to you with those logs if it doesn’t work.

    Sorry for the long message, I just wanted to include everything to help you help me.
    Thanks and regards,

    Jamie.

    #9875
    AvatarDarknite999
    Participant

    Hello Nars,

    Update this morning.

    I believe the problem is connected to AVC pack. So, I believe NoMachine is now functioning correctly as it should when and only when I don’t specify the codec to use. When you don’t specify the codec it defaults to VP8 and NoMachine seems to be working fine.

    If I specify I want to use H.264, I now get a new error instead (just below). I do want to use H.264 codec as I paid for a AVC pack licence.

    The session negotiation failed.
    Error: Cannot attach to local server.

    Please find attached Zipped logs and requested info. I also sent this to the email address you specified forum[ at ]nomachine[dot]com with the subject “Darknite999 – NoMachine requesting authentication from the desktop user to connect”.

    Thanks,

    Jamie.

    Attachments:
    #9885
    AvatarBritgirl
    Keymaster

    Darknite999, please read the article here about enabling debug logs https://www.nomachine.com/DT07M00098

    Reproduce the problem, zip them up and send to forum[at]nomachine[dot]com. Sorry this wasn’t mentioned in Nars’ reply.

    #9890
    AvatarDarknite999
    Participant

    Hi Britgirl/Nars,

    Please provide the exact instructions you want me to follow.  I don’t understand which part of the information within the link that you have sent me that you require me to do as you have not clearly stated.

    Have I not recorded any of the issues to the log?  If this is the case, this has made me highly frustrated now, I managed to provide copious amounts of information to you guys and followed all the instructions given by you and responded in a timely manner.

    Please clearly say what it is you would like me to do as just sending me a link is not clear enough sorry.

    Here are the unanswered questions from my previous replies, please can I have an answer to these 2 questions:

    1. I will try the suggestion about editing the server file manually and let you know how this goes in my next reply. Do I add this line at the end of the server config file?
    2. I have not updated the AVC pack since I updated the NoMachine version, would this be important?

     

     

    THANKS AND REAGRDS,

     

    Jamie.

    #9900
    AvatarBritgirl
    Keymaster

    There was no evidence of a session having been started in the logs you sent us, so we can only assume that you sent us the logs from the client side (the machine you are connecting from) rather than than server side (from the machine that you want to connect to).

    Enabling debug on the server side is essential for us to see why you are not able to connect to that machine. Once enabled, start a session and then zip up the logs that will have been created.

    To enable these logs, go to the folder of the NoMachine installation on the machine you want to connect to, and in the /etc/server.cfg, uncomment (remove the #) where it says SESSION LOGS and set it to 7. This is the same place where you can append the key “PhysicalDesktopAuthorization 0″ in which Nars suggested you do in an earlier reply. Placing it at the end is fine.

     

    1. I have not updated the AVC pack since I updated the NoMachine version, would this be important?

    The version of the pack should not be causing compatibility problems.

    Send the logs to forum[at]…..

Viewing 8 posts - 1 through 8 (of 8 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.