NoMachine resize on startup always displays scroll bars

Forums / NoMachine for Windows / NoMachine resize on startup always displays scroll bars

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #20056
    noone
    Participant

    Can you help me to fix this problem.

    When ever I start NoMachine player in not fullscreen window, I see scrollbars and I need to manually resize remote screen or use scaling mode.

    When I start client in fullscreen then remote screen is correctly displayed. On Windows Remote Desktop client and TV I don’t have this problem.

    #20064
    Britgirl
    Keymaster

    Did you try to use a different resolution instead of the one of the client? To do so, disable the option “Match the client resolution upon connecting” and select a different geometry from the list available in the Display settings panel.

    By enabling the “Fit to window” option it should be possible to achieve a better balance between server and client scaling, offering the desired look.

    Further references:
    https://www.nomachine.com/changing-how-you-view-the-remote-host
    https://www.nomachine.com/DT10O00156#5

    #20133
    noone
    Participant

    I have seen problem is related to the default option “Match the client resolution upon connecting” that is always wrong.

    For example on client side my NoMachine window size is 1378×764, and my Display size is 1920×1050. In that case with default option enabled NoMachine changes size of my remote desktop to 1920×1050 and not to my window size 1378×754.

    I do think it would be better that that option should use player window size rather then the Display size.

    thanks

    #20137
    Tor
    Contributor

    Hi.
    Can you verify if your Windows server supports the resolution 1378×764? You can find the list of available geometries in Windows display settings. It would be great if you take a screenshot of the combo popup listing them.

    #20340
    noone
    Participant

    I see that i did not mention, i am using evaluation version of Workstation and virtual desktops. resolution of the real desktop was already sent to the session, but it uses my full size screen to set the resolution.

    I propose that you option “Change the server resolution to match the client when i connect” takes NoMachine player window resolution and assigns it to the server, not client’s fullscreen resolution.

    Screenshot explains my issue after connection (first resolution on the top is the my current window size resolution)

    #20374
    Tor
    Contributor

    Hi. Thank you for sharing further information.
    The option you’re mentioning is useful if you want to work with fullscreen window. If you plan instead to just use windowed mode and since you’re creating a virtual desktop, I’d suggest to enable the option “Resize remote screen” in the Display menu and to check the box “Remember current window size and position” in the Disconnection panel.

    #20383
    noone
    Participant

    The option you’re mentioning is useful if you want to work with fullscreen window.

    I am exactly talking about this, but i never sow someone here at the university to start the player in the full screen.

    That is why i did propose that that option works like this
    – If player is started in the full screen (use full screen resolution to set)
    – if player is started in window mode disable that function/ or use window resolution to send.

    #20420
    Tor
    Contributor

    – If player is started in the full screen (use full screen resolution to set)
    – if player is started in window mode disable that function/ or use window resolution to send.

    What you are proposing is exactly what the option “Resize remote screen” does.

    If you want to pre-configure your clients in order to disable “Match resolution” option and enable the “Resize screen” option, you could create a template connection file (NXS) and distribute it to your users.
    Identify these keys in the connection file and change their values accordingly:

    <option key="Resize the remote screen to the local geometry" value="false" />
    <option key="Enable session auto-resize" value="true" />
    #20486
    noone
    Participant

    That is clear.
    Lets think about the idea that “Resize screen” is not default option, but the option “Match resolution” that is doing wrong behaviour in the window mode. As I said it is OK in the full-screen mode that no person is using.

    So or they need to save settings or they need to make new connection and to execute few more clicks as they do not want scroll bars.

    Other remote products do not behave like yours.

    But if you don’t want to think outside of the box, I gave up.

    Thank you

    #20532
    Tor
    Contributor

    Creating a graphical interface offering the best experience for as many users as possible is our main focus. The ‘match resolution’ option was added after evaluating many feedbacks, so you can be sure there are users who are enjoying it.
    Nevertheless as I said we’re always focused on improving user experience, therefore we’re evaluating a way to allow to configure both resolution change options (window or screen size). In order to be effective we’ll need to skip the resize by default, and let the user choose the most suitable option. Also, resizing a physical desktop to the window size may not always be possible, because there may be some limitations on setting the display resolution to an arbitrary geometry. In such a case the desktop will be resized to a resolution among those available which is close to the one requested.

    #20536
    noone
    Participant

    I perfectly understand your point.

    About this I am sorry, but i must comment this: 

    option was added after evaluating many feedbacks

    I am sure this evaluation was done at list 6 years ago when people did not have enough available RAM and screen size like now. Please try to run same evaluation now days.

    Thanks
    You can close this topic

    #20560
    Tor
    Contributor

    I don’t know why you think that small RAM or screen size should prevent users from working in fullscreen mode. That option is just related to user experience, and our big efforts on optimization and performance for all screen sizes and available hardware specs are unrelated to that.
    As I said we listen to our user feedback, and this is why we’re seriously evaluating your proposal. If 6 years ago you had proposed the same thing, now that option would be working differently! 😉

    #20574
    noone
    Participant

    Thank you for considering my proposal

    #20834
    Tor
    Contributor

    Hi. We’ve published this feature request to track your proposal, you could subscribe to it to know when it’ll be released:

    https://www.nomachine.com/FR12P03755

Viewing 14 posts - 1 through 14 (of 14 total)

This topic was marked as closed, you can't post.