NoMachine screen lags significantly

Forums / NoMachine for Linux / NoMachine screen lags significantly

Tagged: , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #35572
    r2d2
    Participant

    I connect to a remote server and when working over a NoMachine session, the screen lags significantly, particularly when I scroll in the editor or Jupyter notebook I’m writing code in.  During this action, NoMachine will freeze and then the little spinning icon will display for a few seconds before performance resumes normally for about 5 seconds, whereupon NoMachine will freeze yet again.

    It’s as if the NoMachine session isn’t able to render the display fast enough.

    I’ve tried myriad attempts to solve this, from lowering the display quality scrollbar all the way to the left (lowest quality) to lowering the client resolution down to 1280×720.
    Initially, I suspected a poor network connection, as the lag was symptomatic of a low-bandwidth connection over wifi (despite having no issues streaming video conferences).  But I changed my client connection from wifi to Ethernet hardwire connection and that had zero effect.

    The display monitor on the remote server is turned off (and I have zero control over this) so I suspect that this issue could be related to https://knowledgebase.nomachine.com/FR03S04105

    as described on this topic:  https://forums.nomachine.com/topic/poor-performance-lag-when-host-screen-is-off

    That KB shows it as “low priority” and I’d like to request this “feature” be moved to high priority, as it apparently has had zero progress since it was last updated in March 2021.
    Presently the NoMachine connection is nearly unusable due to the significant lag.

    #35646
    Carin
    Participant

    Hi r2d2,

    To help us with the investigation, can you please collect and send us both client and server-side logs?
    Please see the following article for guidance: Collect server and client logs manually

    Please send them directly to forum[at]nomachine[dot]com making sure you use the title of the topic in the subject of your email. Thanks!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.