NoMachine Ubuntu 18.04 root does not login

Forums / NoMachine for Linux / NoMachine Ubuntu 18.04 root does not login

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #19500
    infoxtreme
    Participant

    Hi,

    My server dedicated SO ubuntu 18.04 server I decided to install desktop + NoMachine

    apt-get install ubuntu-desktop

    Disable Wayland and enable Xorg display server on Ubuntu 18.04

    nano /etc/gdm3/custom.conf

    #WaylandEnable=false

    to

    WaylandEnable=false

    wget -4 -O https://download.nomachine.com/download/6.2/Linux/nomachine_6.2.4_1_i386.deb

    sudo dpkg -i nomachine_6.2.4_1_i386.deb

     

    Login user root error pass, but the password is correct, I can log in with root via SSH

    with other NoMachine users works

    I want to log in and work with root

     

    [img]https://i.imgur.com/h1f31lW.jpg[/img]

     

    Best Regards

     

     

    Attachments:
    #19515
    kroy
    Contributor

    Login as root is disabled in the system by the default. For security reasons we do not recommend to enable it. But if you are aware of the dangers and you are sure that you want to enable root login, you should edit /etc/gdm3/custom.conf by adding the line AllowRoot=true below [security] section. Save the file and exit.

    Then edit /etc/pam.d/gdm-password and comment the line (add # sign at the beginning of the line) auth required pam_succeed_if.so user != root quiet_success.

    Reboot your system after making the changes.

    #19700
    infoxtreme
    Participant

    Thanks now works perfectly

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.