NoMachine version 4.2.23 now available

Forums / General Discussions / NoMachine version 4.2.23 now available

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3654
    AvatarBritgirl
    Keymaster

    To all NoMachine users,

    NoMachine makes available today an update aimed at solving issues affecting the previous 4.2 releases. The new version, 4.2.23, provides fixes for the following:

    TR03L04333 – The Windows Logo + m shortcut doesn’t minimize the client when it’s at fullscreen
    TR03L04319 – ‘No running nodes found’ when a customized SSHD port is used
    TR05L04400 – Virtual KDE desktop crashes while cycling through ‘Window Decoration’ options
    TR10K03970 – Cannot connect to the physical desktop when the display manager is LXDM
    TR04L04375 – Cannot connect to the physical desktop on OpenSUSE 13.1 when there is the login screen
    TR05L04398 – Server issues an incorrect message when creating a rule with an invalid value
    TR05L04413 – Pop-up menus show in random places connecting from multi-monitor Windows client
    TR05L04397 – Cannot create a rule for running a specific script in case of custom session
    TR05L04418 – Cannot change server connection preferences in the GUI if the administrative account has an empty password
    TR05L04403 – Cannot set profile rules on per-group basis with the Terminal Server
    TR05L04422 – Custom sessions from Windows fails to start with ‘Protocol error’
    TR12K04170 – Custom sessions cannot be automatically reconnected
    TR04L04393 – /var/NX/nx directory fills up consuming disk space
    TR05L04423 – Authentication fails when NoMachine is installed on RHEL 4
    TR05L04406 – Connections to localhost fail in a multinode environment
    TR05L04424 – Cannot maximize the session window with the Windows logo + up arrow shortcut
    TR05L04427 – Not possible to reconnect the session when changing the network connection type

    and implements the following feature requests:

    FR04L02813 – Forwarding the SSH_CLIENT and SSH_CONNECTION variables to the session
    FR05L02815 – Adding support for SSH connections when connecting from Android

    Supported Platforms

    Windows 32-bit/64-bit XP/Vista/7/8

    Mac OS X Intel 64-bit 10.5/10.6/10.7/10.8/10.9

    Linux 32-bit and 64-bit
    Red Hat Enterprise 4/5/6
    SLES 10/11
    Open SUSE 10.x/11.x/12.x
    Mandriva 2009/2010/2011
    Fedora Core 10/11/12/13/14/15/16/17/18
    Debian GNU Linux 4.0 Etch/5.0 Lenny/ 6.0 Squeeze/ 7.0 Wheezy
    Ubuntu 8.04 Hardy Heron/8.10 Intrepid Ibex/Ubuntu 9.04 Jaunty Jackalope/
    9.10 Karmic Koala/10.4 Lucid Lynx/10.10 Maverick/11.04 Natty/11.10 Oneiric/12.04 Precise Pangolin

    Download NoMachine Packages

    You can download the latest packages suitable for your Operating System from the NoMachine Web site at the following URL:

    http://www.nomachine.com/download

    Or from your Customer Area if you are a registered customer.


    Note for Android users

    With this particular release, users of the NoMachine for Android app are advised to uninstall the previous APK before installing this latest version.


    Automatic updates

    To update any of the NoMachine servers:

    – Run the NoMachine GUI from your Programs Menu.

    – Click on ‘Preferences’ and ‘Updates’.

    – Then click on the ‘Check now’ button.

    To update the NoMachine Enterprise Client:

    – Click on ‘Preferences’ and ‘Updates’.

    – Then click on the ‘Check now’ button.

    Manual package update

    Please follow the instructions to update your installation manually:

    On Windows:

    – Download and save the EXE file.
    – Double click on the NoMachine executable file.
    – As for the installation, the Setup Wizard will take you through all steps necessary for updating NoMachine.

    On Mac OS X:

    – Download and save the DMG file.
    – Double-click on the Disk Image to open it and double-click on the NoMachine program icon.
    – As for the installation, the Installer will take you through through all steps necessary for updating NoMachine.

    On Linux:

    You can use the graphical package manager provided by your Linux distribution or update NoMachine by command line by following instructions below.
    If you don’t have the sudo utility installed, log on as superuser (“root”) and run the commands without sudo.

    RPM

    – Download and save the RPM file.
    – Update your NoMachine installation by running:

    # rpm -Uvh <pkgName>_<pkgVersion>_<arch>.rpm

    DEB

    – Download and save the DEB file.
    – Update your NoMachine installation by running:

    $ sudo dpkg -i <pkgName>_<pkgVersion>_<arch>.deb

    TAR.GZ

    – Download and save the TAR.GZ file.
    – Update your NoMachine installation by running:

    $ cd /usr
    $ sudo tar xvzf <pkgName>_<pkgVersion>_<arch>.tar.gz
    $ sudo /usr/NX/nxserver –update

    If you are installing Enterprise Client or Node run respectively:

    $ sudo /usr/NX/nxclient –update
    $ sudo /usr/NX/nxnode –update

    Documents

    Installation and configuration guides for the NoMachine products are available at:

    http://www.nomachine.com/documents

    The NoMachine Development Team

    #3696
    Avatarmisha
    Participant

    Hi installed this version on ubuntu 14.4 and it does not work.

    this is the output I get when I try to run the nxplayer:

    misha@misha-Latitude-D610:~$ /usr/NX/bin/nxplayer
    Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 70: non-double matrix element
    Fontconfig error: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 70: non-double matrix element
    Fontconfig warning: “/etc/fonts/conf.d/10-scale-bitmap-fonts.conf”, line 78: saw unknown, expected number
    Bus error (core dumped)

    How can I run the NX application to connect to the NX Server 4.

     

    thanks

     

    #3719
    AvatarBritgirl
    Keymaster

    Hi Misha,

    can you contact our team using this form and we will explain what the next steps are.

    https://www.nomachine.com/report-issues

     

     

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as closed, you can't post.